openwrt/svn-archive/archive.git
8 years ago[packages] dash: update to 0.5.7
Stephen Walker [Sat, 3 Sep 2011 22:51:52 +0000 (22:51 +0000)]
[packages] dash: update to 0.5.7

SVN-Revision: 28155

8 years ago[packages] radvd: update to 1.8.1, remove obsolete patch
Stephen Walker [Sat, 3 Sep 2011 22:51:16 +0000 (22:51 +0000)]
[packages] radvd: update to 1.8.1, remove obsolete patch

SVN-Revision: 28154

8 years ago[packages] perl: remove Peter as he is no longer the maintainer
Stephen Walker [Sat, 3 Sep 2011 19:32:22 +0000 (19:32 +0000)]
[packages] perl: remove Peter as he is no longer the maintainer

SVN-Revision: 28153

8 years ago[packages] ditg: fix md5sum
Stephen Walker [Sat, 3 Sep 2011 06:28:50 +0000 (06:28 +0000)]
[packages] ditg: fix md5sum

SVN-Revision: 28152

8 years ago[packages] lighttpd: add .svn mimetype (#10016)
Jo-Philipp Wich [Thu, 1 Sep 2011 20:04:24 +0000 (20:04 +0000)]
[packages] lighttpd: add .svn mimetype (#10016)

SVN-Revision: 28146

8 years agoupdated with zeromq-2.1.9
Mazi Lo [Thu, 1 Sep 2011 18:54:52 +0000 (18:54 +0000)]
updated with zeromq-2.1.9

SVN-Revision: 28145

8 years agoupgrade mc package
Luka Perkov [Tue, 30 Aug 2011 21:02:36 +0000 (21:02 +0000)]
upgrade mc package

SVN-Revision: 28135

8 years ago[packages] php5: upgrade to 5.3.8 and refresh patches
Michael Heimpold [Tue, 30 Aug 2011 19:45:14 +0000 (19:45 +0000)]
[packages] php5: upgrade to 5.3.8 and refresh patches

SVN-Revision: 28131

8 years ago[packages] binutils: do not configure with system root set to pkg install, it will...
Jo-Philipp Wich [Tue, 30 Aug 2011 18:39:38 +0000 (18:39 +0000)]
[packages] binutils: do not configure with system root set to pkg install, it will not exist on target and all default search paths become invalid

SVN-Revision: 28130

8 years agoupdated to latest git version, added HU lang support, and minor fixes to the Makefile
Mazi Lo [Tue, 30 Aug 2011 00:22:55 +0000 (00:22 +0000)]
updated to latest git version, added HU lang support, and minor fixes to the Makefile

SVN-Revision: 28128

8 years ago[packages] php5: PECL: include support for http
Michael Heimpold [Mon, 29 Aug 2011 19:43:23 +0000 (19:43 +0000)]
[packages] php5: PECL: include support for http

SVN-Revision: 28123

8 years ago[packages] pulseaudio: update to 1.0-rc3
Jan Willies [Mon, 29 Aug 2011 17:46:04 +0000 (17:46 +0000)]
[packages] pulseaudio: update to 1.0-rc3

SVN-Revision: 28121

8 years ago[packages] openvpn: fix lzo dependency and rename config options
Jan Willies [Mon, 29 Aug 2011 15:31:32 +0000 (15:31 +0000)]
[packages] openvpn: fix lzo dependency and rename config options

SVN-Revision: 28120

8 years ago[packages] babel: upstream release 1.1.99.1
Gabriel Kerneis [Mon, 29 Aug 2011 12:53:22 +0000 (12:53 +0000)]
[packages] babel: upstream release 1.1.99.1

* INCOMPATIBLE CHANGE: default port changed to 6696
* New option: 'diversity'

SVN-Revision: 28119

8 years ago[package] add simplejson
Florian Fainelli [Sun, 28 Aug 2011 12:08:38 +0000 (12:08 +0000)]
[package] add simplejson

THe simplejson is a json encoder/decoder for python it is a lot faster
(close to 10x) than the json module that ships with python.

A special thanks to Jan Willies for the feedback on the distribute package.

Signed-off-by: Roberto Riggio <roberto.riggio@create-net.org>
SVN-Revision: 28105

8 years ago[package] usb-modeswitch: update to 1.1.9
Florian Fainelli [Sun, 28 Aug 2011 12:08:35 +0000 (12:08 +0000)]
[package] usb-modeswitch: update to 1.1.9

patch from Alexander Khryukin.

SVN-Revision: 28104

8 years ago[package] usb-modeswitch-data: bump to 20110805
Florian Fainelli [Sun, 28 Aug 2011 12:08:33 +0000 (12:08 +0000)]
[package] usb-modeswitch-data: bump to 20110805

The update is required as the old filename
usb-modeswitch-data-20110705.tar.bz2 is no longer hosted on
http://www.draisberghof.de/usb_modeswitch/
BTW, the two openwrt.org backup servers do not hold either the old
usb-modeswitch-data-20110705.tar.bz2 nor the new
usb-modeswitch-data-20110805.tar.bz2
In effect there is a dependency on one external server. If they decide
to change to a new version and not continue hosting the old, the
compilation breaks. The sources on the openwrt,org servers should
therefore be urgently updated.

Signed-off-by: Hanno Schupp <hanno.schupp@gmail.com>
SVN-Revision: 28103

8 years ago[package] ipsec-tools: update to 0.8.0, add init script
Florian Fainelli [Sun, 28 Aug 2011 12:08:31 +0000 (12:08 +0000)]
[package] ipsec-tools: update to 0.8.0, add init script

Signed-off-by: Artem Makhutov <artem@makhutov.org>
SVN-Revision: 28102

8 years ago[package] ffmpeg: fix typo in Makefile
Florian Fainelli [Sun, 28 Aug 2011 12:08:30 +0000 (12:08 +0000)]
[package] ffmpeg: fix typo in Makefile

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
SVN-Revision: 28101

8 years ago[package] axtls: updae to 1.4.3
Florian Fainelli [Sun, 28 Aug 2011 12:08:28 +0000 (12:08 +0000)]
[package] axtls: updae to 1.4.3

I'm the developer of axTLS. I've got an update to use the latest
version. Hopefully nothing too dramatic here.

Signed-off-by: Cameron Rich <camster444@gmail.com>
SVN-Revision: 28100

8 years ago[package] libosip2: minor fix for libosip2 package
Florian Fainelli [Sun, 28 Aug 2011 12:08:27 +0000 (12:08 +0000)]
[package] libosip2: minor fix for libosip2 package

Remove unneeded configure flags and add support for parallel build.

No need to bump the PKG_RELEASE.

Signed-off-by: Luka Perkov <openwrt@lukaperkov.net>
SVN-Revision: 28099

8 years ago[package] openvpn: update to 2.2.1, reorganize makefile
Florian Fainelli [Sun, 28 Aug 2011 12:08:25 +0000 (12:08 +0000)]
[package] openvpn: update to 2.2.1, reorganize makefile

Upgrade to new version, add menu, refresh patches and reorganize
Makefile.

Signed-off-by: Luka Perkov <openwrt@lukaperkov.net>
SVN-Revision: 28098

8 years ago[package] reorganize siproxd package
Florian Fainelli [Sun, 28 Aug 2011 12:08:23 +0000 (12:08 +0000)]
[package] reorganize siproxd package

Reorganize siproxd package, add better plugins support and revert to
shared plugins.

Signed-off-by: Luka Perkov <openwrt@lukaperkov.net>
SVN-Revision: 28097

8 years ago[packages] paris-traceroute: add paris-traceroute
Stephen Walker [Sat, 27 Aug 2011 19:13:44 +0000 (19:13 +0000)]
[packages] paris-traceroute: add paris-traceroute

SVN-Revision: 28092

8 years ago[packages] ditg: update to 2.8.0-rc1, remove obsolete patch
Stephen Walker [Sat, 27 Aug 2011 19:12:45 +0000 (19:12 +0000)]
[packages] ditg: update to 2.8.0-rc1, remove obsolete patch

SVN-Revision: 28091

8 years ago[package] lcd4linux: fix new plugins that were added during bump to r1158
Jonathan McCrohan [Fri, 26 Aug 2011 21:10:48 +0000 (21:10 +0000)]
[package] lcd4linux: fix new plugins that were added during bump to r1158

SVN-Revision: 28090

8 years ago[package] lcd4linux: bump to r1158
Jonathan McCrohan [Thu, 25 Aug 2011 22:56:41 +0000 (22:56 +0000)]
[package] lcd4linux: bump to r1158

SVN-Revision: 28088

8 years ago[package] Fix mysql dependencies
Florian Fainelli [Thu, 25 Aug 2011 10:10:38 +0000 (10:10 +0000)]
[package] Fix mysql dependencies

Trying to fix some issues with php5 I discoverd that php5's mysql extension doesn't load:

<snip>
root@OpenWrt:/tmp# php-cli -m
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/mysql.so' - File not found in Unknown on line 0
[PHP Modules]
Core
ctype
curl
date
ereg
gettext
json
openssl
pcntl
pcre
posix
Reflection
session
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
zlib

[Zend Modules]
</snap>

After installing uclibcxx, the extension loads fine:

<snip>
root@OpenWrt:/tmp# opkg install uclibcxx
Installing uclibcxx (0.2.2-3) to root...
Downloading http://192.168.1.2:8081/brcm47xx/packages/uclibcxx_0.2.2-3_brcm47xx.ipk.
Configuring uclibcxx.
root@OpenWrt:/tmp# php-cli -m
[PHP Modules]
<...>
mysql
<...>

[Zend Modules]
</snap>

So the mysqlclient library needs uclibcxx, not only mysql-server. But since
mysql-server is depended of the mysqlclient library we can shorten its dependencies.

I also cross-checked that e.g. a mysql-enabled lighttpd shows the same behaviour
when uclibcxx is not installed.
<snip>
root@OpenWrt:/tmp/log/lighttpd# lighttpd -f /etc/lighttpd/lighttpd.conf
1970-01-01 05:07:30: (plugin.c.169) dlopen() failed for: /usr/lib/lighttpd/mod_mysql_vhost.so File not found
1970-01-01 05:07:30: (server.c.650) loading plugins finally failed
</snap>

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 28083

8 years ago[package] wide-dhcpv6: improve user DUID handling
Jo-Philipp Wich [Mon, 22 Aug 2011 22:50:16 +0000 (22:50 +0000)]
[package] wide-dhcpv6: improve user DUID handling
- values containing exactly six octets are treated as type 3 (DUID-LL)
- values containing seven and more octets get the length tag added in native endianess
- all other values are treated as invalid

SVN-Revision: 28079

8 years ago[packages] asterisk-1.8.x: refresh patches
Hans Zandbelt [Mon, 22 Aug 2011 11:26:02 +0000 (11:26 +0000)]
[packages] asterisk-1.8.x: refresh patches

SVN-Revision: 28072

8 years ago[packages] asterisk-1.8.x: fix chan_gtalk (#9976)
Hans Zandbelt [Mon, 22 Aug 2011 11:25:37 +0000 (11:25 +0000)]
[packages] asterisk-1.8.x: fix chan_gtalk (#9976)

SVN-Revision: 28071

8 years ago[packages] asterisk-1.8.x: add chan_skinny (#9756) fix voicemail res_smdi inclusion...
Hans Zandbelt [Mon, 22 Aug 2011 11:24:32 +0000 (11:24 +0000)]
[packages] asterisk-1.8.x: add chan_skinny (#9756) fix voicemail res_smdi inclusion (#9748)

SVN-Revision: 28070

8 years ago[packages] pulseaudio: use PKG_CONFIG_LIBDIR
Jan Willies [Mon, 22 Aug 2011 06:48:56 +0000 (06:48 +0000)]
[packages] pulseaudio: use PKG_CONFIG_LIBDIR

SVN-Revision: 28068

8 years ago[packages] libsndfile: fix large file support (#9955), thanks jow for tracking this...
Jan Willies [Mon, 22 Aug 2011 06:48:53 +0000 (06:48 +0000)]
[packages] libsndfile: fix large file support (#9955), thanks jow for tracking this down

SVN-Revision: 28067

8 years agobatman-adv: upgrade package to latest release (2011.3.0)
Marek Lindner [Sun, 21 Aug 2011 23:45:09 +0000 (23:45 +0000)]
batman-adv: upgrade package to latest release (2011.3.0)

Also split init script into lib and init script as suggested by
Filippo Sallemi to allow including the lib from a hotplug script.

Signed-off-by: Marek Lindner <lindner_marek@yahoo.de>
SVN-Revision: 28066

8 years ago[packages] libsndfile: update to 1.0.25
Jan Willies [Sun, 21 Aug 2011 14:41:10 +0000 (14:41 +0000)]
[packages] libsndfile: update to 1.0.25

SVN-Revision: 28065

8 years ago[package] vips: update to 7.26.1 (#9666)
Florian Fainelli [Sat, 20 Aug 2011 12:15:37 +0000 (12:15 +0000)]
[package] vips: update to 7.26.1 (#9666)

SVN-Revision: 28064

8 years ago[package] ffmpeg: 0.8.2 Version Bump (#8831)
Florian Fainelli [Sat, 20 Aug 2011 11:27:00 +0000 (11:27 +0000)]
[package] ffmpeg: 0.8.2 Version Bump (#8831)

FFmpeg 0.8.2 Version Bump (#8831)

Dropped configure options:
--disable-ipv6: IPv6 is no longer a separate switch. It's network aware or isn't.
--disable-libfaad: This switch isn't listed as part of ./configure --help.
--disable-vhook: vhook is no longer a part of ffmpeg.

Added configure options:
--disable-doc: Disables documentation
--disable-dxva2: Disables Microsoft's DirectX Video Acceleration v2
--enable-version3: Builds GPLv3 code
--disable-filters: Disables audio/video stream processing filters
--disable-hwaccels: Disables hardware video playback acceleration
--disable-ffplay: FFplay is a SDL(?) based media player.

Dropped formats:
oss is not listed in ./configure --list-muxers
mpeg4aac is not listed in ./configure --list-decoders

Configure options were reordered to roughly be:

Generic program configure switches
Libav* feature options
Binary selection

All of the libav* feature disabling was done at once. This is to keep from second guessing FFmpeg's internal dependency checking when we start enabling options.

Added options to keep from mass disabling encoders/muxers and decoders/demuxers. This should address #8831's issue.

Added option to build FFprobe. FFprobe is a command line media identification tool, very similar to the output of a bare ffmpeg -i.

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
SVN-Revision: 28063

8 years ago[package] vips: update to 7.24.5
Florian Fainelli [Sat, 20 Aug 2011 11:26:58 +0000 (11:26 +0000)]
[package] vips: update to 7.24.5

This updates to VIPS 7.24.5 and includes the im_bufjpeg2vips function,
backported from Git master.

Signed-off-by: W. Michael Petullo <mike at flyn.org>
SVN-Revision: 28062

8 years ago[package] coova-chilli: update to 1.2.8
Florian Fainelli [Sat, 20 Aug 2011 11:26:57 +0000 (11:26 +0000)]
[package] coova-chilli: update to 1.2.8

Signed-off-by: Hanno Schupp <hanno.schupp@gmail.com>
SVN-Revision: 28061

8 years ago[package] shorewall6-lite: fix typo in category name
Florian Fainelli [Sat, 20 Aug 2011 11:26:55 +0000 (11:26 +0000)]
[package] shorewall6-lite: fix typo in category name

SVN-Revision: 28060

8 years ago[package] shorewall6-lite: remove ip6tables-utiles dependency after r27961
Florian Fainelli [Sat, 20 Aug 2011 11:26:54 +0000 (11:26 +0000)]
[package] shorewall6-lite: remove ip6tables-utiles dependency after r27961

SVN-Revision: 28059

8 years ago[package] shorewall6-lite: update to 4.4.22.2
Florian Fainelli [Sat, 20 Aug 2011 11:26:49 +0000 (11:26 +0000)]
[package] shorewall6-lite: update to 4.4.22.2

Signed-off-by: Edy Corak info@loenshotel.de
SVN-Revision: 28058

8 years ago[packages] hplib: ship SANE configuration (#9964)
Jo-Philipp Wich [Fri, 19 Aug 2011 23:35:30 +0000 (23:35 +0000)]
[packages] hplib: ship SANE configuration (#9964)

SVN-Revision: 28055

8 years ago[packages] pulseaudio: always build pulseaudio-tools sans dbus (#9956)
Jan Willies [Fri, 19 Aug 2011 09:35:06 +0000 (09:35 +0000)]
[packages] pulseaudio: always build pulseaudio-tools sans dbus (#9956)

SVN-Revision: 28046

8 years ago[packages] pulseaudio: fix VARIANT building (#9952)
Jan Willies [Thu, 18 Aug 2011 21:03:34 +0000 (21:03 +0000)]
[packages] pulseaudio: fix VARIANT building (#9952)

SVN-Revision: 28045

8 years agorework pulseaudio package:
Jan Willies [Thu, 18 Aug 2011 13:44:20 +0000 (13:44 +0000)]
rework pulseaudio package:
- split pulseaudio into pulseaudio-daemon and pulseaudio-daemon-avahi
- cleanup dependencies (remove OSS, libsamplerate, manpages)
- add conffiles section
- rename pa-tools to pulseaudio-tools
- add pulseaudio-profiles package
- refresh patches

SVN-Revision: 28044

8 years ago[packages] uftp: add uftp, a multicast ftp client, server & proxy
Stephen Walker [Thu, 18 Aug 2011 09:04:27 +0000 (09:04 +0000)]
[packages] uftp: add uftp, a multicast ftp client, server & proxy

SVN-Revision: 28037

8 years ago[packages] nuttcp: add nuttcp, a network perf tool
Stephen Walker [Thu, 18 Aug 2011 09:03:54 +0000 (09:03 +0000)]
[packages] nuttcp: add nuttcp, a network perf tool

SVN-Revision: 28036

8 years ago[packages] utils/boxbackup: Corrected refresh (delete, touch) before rebuild of the...
Daniel Dickinson [Thu, 18 Aug 2011 08:57:52 +0000 (08:57 +0000)]
[packages] utils/boxbackup: Corrected refresh (delete, touch) before rebuild of the raidfile configuration.  It was happening for every set instead of only before the first set.

SVN-Revision: 28035

8 years agoVersion Bump Minidlna 1.0.21
Jan Willies [Thu, 18 Aug 2011 08:27:29 +0000 (08:27 +0000)]
Version Bump Minidlna 1.0.21

Adjust minidlna for inotify becoming part of the default kernel.

minidlna.init: stop forcing a rescan (-R) of the media library on startup. Users will need to run it once after installing.

040-configuration-tweak.patch: enable use of inotify in the default configuration

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
SVN-Revision: 28034

8 years ago[package] elfutils: rename libelf to libelf1
Florian Fainelli [Wed, 17 Aug 2011 14:37:25 +0000 (14:37 +0000)]
[package] elfutils: rename libelf to libelf1

SVN-Revision: 28032

8 years ago[package] minidlna: update to 1.0.21
Florian Fainelli [Wed, 17 Aug 2011 10:13:21 +0000 (10:13 +0000)]
[package] minidlna: update to 1.0.21

010-genconfig-checks.patch adjusts two configure checks to use ICONV_PREFIX and INTL_PREFIX. These changes were already made previously elsewhere in the build process and looks like it was just overlooked here.

040-configuration-tweak.patch was to rebase.

Minidlna's changes were primarily bug fixes and compatibility with newer ffmpeg.

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
SVN-Revision: 28031

8 years ago[package] add fwknopd
Florian Fainelli [Wed, 17 Aug 2011 10:13:20 +0000 (10:13 +0000)]
[package] add fwknopd

Signed-off-by; Jonathan Bennett <jbscience87@gmail.com>

SVN-Revision: 28030

8 years ago[package] siproxd: update to 0.8.1
Florian Fainelli [Wed, 17 Aug 2011 10:13:19 +0000 (10:13 +0000)]
[package] siproxd: update to 0.8.1

Upgrade siproxd, fix init script, link statically with libosip2 (size)
and add description.

Signed-off-by: Luka Perkov <openwrt@lukaperkov.net>
SVN-Revision: 28029

8 years ago[package] elfutils: add back libelf, package is marked BROKEN
Florian Fainelli [Wed, 17 Aug 2011 10:13:17 +0000 (10:13 +0000)]
[package] elfutils: add back libelf, package is marked BROKEN

SVN-Revision: 28028

8 years ago[packages] dbus: remove empty patches directory
Stephen Walker [Wed, 17 Aug 2011 09:32:11 +0000 (09:32 +0000)]
[packages] dbus: remove empty patches directory

SVN-Revision: 28027

8 years ago[packages] utils/boxbackup: Added boxbackup. Currently only the server is fully...
Daniel Dickinson [Tue, 16 Aug 2011 22:10:23 +0000 (22:10 +0000)]
[packages] utils/boxbackup: Added boxbackup.  Currently only the server is fully integrated (init script and uci), but it compiles and the server works.

SVN-Revision: 28023

8 years ago[packages] remove json-c, its in trunk already
Jan Willies [Tue, 16 Aug 2011 21:10:55 +0000 (21:10 +0000)]
[packages] remove json-c, its in trunk already

SVN-Revision: 28020

8 years ago[packages] pulseaudio: change json dependency
Jan Willies [Tue, 16 Aug 2011 21:10:51 +0000 (21:10 +0000)]
[packages] pulseaudio: change json dependency

SVN-Revision: 28019

8 years ago[package] autossh: increase reliability of connection behavior
Florian Fainelli [Tue, 16 Aug 2011 20:34:24 +0000 (20:34 +0000)]
[package] autossh: increase reliability of connection behavior

patch from Paul Geraedts

SVN-Revision: 28018

8 years ago[package] strongswan4: add af-alg plugin
Florian Fainelli [Tue, 16 Aug 2011 20:34:22 +0000 (20:34 +0000)]
[package] strongswan4: add af-alg plugin

* Add kernel crypto user-space interface plugin (strongswan4-mod-af-alg)
* Requires kmod-crypto-user

Signed-off-by: Lars Hjersted <lars@hjersted.com>
SVN-Revision: 28017

8 years ago[package] strongswan4: update to 4.5.3
Florian Fainelli [Tue, 16 Aug 2011 20:34:20 +0000 (20:34 +0000)]
[package] strongswan4: update to 4.5.3

Private libraries moved from /usr/lib to /usr/lib/ipsec.

Signed-off-by: Lars Hjersted <lars@hjersted.com>
SVN-Revision: 28016

8 years ago[package] dbus: update to 1.4.14
Florian Fainelli [Tue, 16 Aug 2011 20:34:19 +0000 (20:34 +0000)]
[package] dbus: update to 1.4.14

This bumps dbus in the packages repository to 1.4.14.
It also requires librt now due to clock function usage.
It also supports systemd and launchd now.

Signed-off-by: Daniel Mierswa <impulze@impulze.org>
SVN-Revision: 28015

8 years ago[package] bind: update to 9.8.0-P4
Florian Fainelli [Tue, 16 Aug 2011 20:34:17 +0000 (20:34 +0000)]
[package] bind: update to 9.8.0-P4

Signed-off-by: Alexey I. Froloff <raorn@altlinux.org>
SVN-Revision: 28014

8 years ago[package] ipv6: add tayga
Florian Fainelli [Tue, 16 Aug 2011 20:34:12 +0000 (20:34 +0000)]
[package] ipv6: add tayga

TAYGA is an out-of-kernel stateless NAT64 implementation for
Linux.  It uses the TUN driver to exchange packets with the
kernel, which is the same driver used by OpenVPN and QEMU/KVM.

Signed-off-by: Alexey I. Froloff <raorn@altlinux.org>
SVN-Revision: 28013

8 years ago[package] xl2tpd: update to 1.3.0 (#9921)
Florian Fainelli [Tue, 16 Aug 2011 20:34:10 +0000 (20:34 +0000)]
[package] xl2tpd: update to 1.3.0 (#9921)

SVN-Revision: 28012

8 years ago[package] openl2tp: fix pppd version (#9940)
Florian Fainelli [Tue, 16 Aug 2011 20:34:08 +0000 (20:34 +0000)]
[package] openl2tp: fix pppd version (#9940)

SVN-Revision: 28011

8 years ago[packages] pulseaudio: update to 1.0-rc2
Jan Willies [Tue, 16 Aug 2011 14:12:48 +0000 (14:12 +0000)]
[packages] pulseaudio: update to 1.0-rc2

SVN-Revision: 28009

8 years ago[packages] add json-c
Jan Willies [Tue, 16 Aug 2011 14:12:47 +0000 (14:12 +0000)]
[packages] add json-c

SVN-Revision: 28008

8 years ago[packages] mosquitto: [PATCH] Add support for the mosquitto MQTT message broker,...
Jan Willies [Mon, 15 Aug 2011 14:54:15 +0000 (14:54 +0000)]
[packages] mosquitto: [PATCH] Add support for the mosquitto MQTT message broker, tools and library. Signed-off-by: Karl Palsson<karlp@tweak.net.au>

SVN-Revision: 28001

8 years ago[packages] remove empty patches directories
Stephen Walker [Mon, 15 Aug 2011 05:04:20 +0000 (05:04 +0000)]
[packages] remove empty patches directories

SVN-Revision: 27987

8 years ago[packages] time: add the GNU time utility
Stephen Walker [Mon, 15 Aug 2011 03:38:32 +0000 (03:38 +0000)]
[packages] time: add the GNU time utility

SVN-Revision: 27986

8 years ago[packages] httping: update to 1.5.2, refresh patches
Stephen Walker [Mon, 15 Aug 2011 03:37:19 +0000 (03:37 +0000)]
[packages] httping: update to 1.5.2, refresh patches

SVN-Revision: 27985

8 years ago[packages] tmux: fix librt dependency (#9938)
Jan Willies [Sun, 14 Aug 2011 07:29:18 +0000 (07:29 +0000)]
[packages] tmux: fix librt dependency (#9938)

SVN-Revision: 27981

8 years ago[package] babeld: upstream release 1.1.3
Gabriel Kerneis [Mon, 8 Aug 2011 13:23:37 +0000 (13:23 +0000)]
[package] babeld: upstream release 1.1.3

New option: -u (keep unfeasible routes), called "keep_unfeasible" in UCI.

SVN-Revision: 27933

8 years ago[package] ahcpd: upstream release 0.52
Gabriel Kerneis [Mon, 8 Aug 2011 13:23:35 +0000 (13:23 +0000)]
[package] ahcpd: upstream release 0.52

INCOMPATIBLE CHANGE: client mode configuration cannot be done in
/etc/config/network anymore (at least for this release).  It will
be added back in the near future.

SVN-Revision: 27932

8 years agoadded modules: codecs/mod_opus, endpoints/mod_skypopen, and event_handlers/mod_snmp...
Mazi Lo [Mon, 8 Aug 2011 02:20:17 +0000 (02:20 +0000)]
added modules: codecs/mod_opus, endpoints/mod_skypopen, and event_handlers/mod_snmp. NOTE: mod_skypopen requires a Skype client for the platform to function. Additional information can be found on wiki.freeswitch.org/wiki/Mod_skypopen

SVN-Revision: 27928

8 years agoopenswan: Update Openswan to upstream 2.6.34
Hauke Mehrtens [Sat, 6 Aug 2011 12:17:56 +0000 (12:17 +0000)]
openswan: Update Openswan to upstream 2.6.34

OpenWRT's bulid process currently uses Openswan v2.6.33, which does not build against the 2.6.39 kernel.
This patch updates the OpenWRT build process to build Openswan v2.6.34, released 2011-06-08.

hauke:
 * use Openswan v2.6.35

Signed-off-by: Stephen Oberholtzer <oliverklozoff@gmail.com>
SVN-Revision: 27922

8 years ago[packages] olsrd: Remove 'destination == gateway' routes workaround - should be fixed...
Vasilis Tsiligiannis [Fri, 5 Aug 2011 15:32:23 +0000 (15:32 +0000)]
[packages] olsrd: Remove 'destination == gateway' routes workaround - should be fixed with new Quagga patch

SVN-Revision: 27914

8 years ago[packages] quagga: Fix installing of OLSR host routes
Vasilis Tsiligiannis [Fri, 5 Aug 2011 15:32:18 +0000 (15:32 +0000)]
[packages] quagga: Fix installing of OLSR host routes

SVN-Revision: 27913

8 years ago[packages] at: revert r27801
Jonas Gorski [Thu, 4 Aug 2011 18:51:41 +0000 (18:51 +0000)]
[packages] at: revert r27801

SVN-Revision: 27898

8 years ago[package] elfutils: mark as broken for now
Florian Fainelli [Thu, 4 Aug 2011 10:46:22 +0000 (10:46 +0000)]
[package] elfutils: mark as broken for now

SVN-Revision: 27892

8 years ago[packages] upgrade libosip2 package
Jonas Gorski [Wed, 3 Aug 2011 21:08:39 +0000 (21:08 +0000)]
[packages] upgrade libosip2 package

Upgrade to new version and refresh patches.

Signed-off-by: Luka Perkov < openwrt ->-to->- lukaperkov.net >
SVN-Revision: 27886

8 years ago[packages] pyclips: Add new package pyclips
Hamish Guthrie [Wed, 3 Aug 2011 12:57:49 +0000 (12:57 +0000)]
[packages] pyclips: Add new package pyclips

SVN-Revision: 27884

8 years agoruby: add missing dependency on librt (#9867)
Felix Fietkau [Tue, 2 Aug 2011 09:26:55 +0000 (09:26 +0000)]
ruby: add missing dependency on librt (#9867)

SVN-Revision: 27873

8 years ago[package] elfutils: do not package nor stage libelf for now
Florian Fainelli [Mon, 1 Aug 2011 18:16:00 +0000 (18:16 +0000)]
[package] elfutils: do not package nor stage libelf for now

This is clashing with libs/libelf, and only 'perf' is using this version, so
until we resolve that clashing, do not build libelf from elfutils.

SVN-Revision: 27866

8 years ago[packages] owfs: update to 2.8p13 (#9862)
Stephen Walker [Mon, 1 Aug 2011 02:19:07 +0000 (02:19 +0000)]
[packages] owfs: update to 2.8p13 (#9862)
 * drop unrecognized configure options
 * use MAKE_FLAGS

SVN-Revision: 27858

8 years ago[packages] httping: update to 1.5.1
Stephen Walker [Mon, 1 Aug 2011 02:17:57 +0000 (02:17 +0000)]
[packages] httping: update to 1.5.1
 * add nossl variant
 * drop unused extra_flags patch
 * refresh patches

SVN-Revision: 27857

8 years ago[PATCH] #9863: don't export target $PROFILE into postgresql
Jo-Philipp Wich [Mon, 1 Aug 2011 00:34:09 +0000 (00:34 +0000)]
[PATCH] #9863: don't export target $PROFILE into postgresql
PROFILE is overloaded by postgresql versus how target's define it.

Fixes: https://dev.openwrt.org/ticket/9863

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
SVN-Revision: 27856

8 years ago[packages] tmux: correct the 1.5 platform renaming
Stephen Walker [Sun, 31 Jul 2011 19:48:33 +0000 (19:48 +0000)]
[packages] tmux: correct the 1.5 platform renaming

SVN-Revision: 27854

8 years ago[packages] tmux: change dependency to libevent2
Jan Willies [Sun, 31 Jul 2011 15:19:53 +0000 (15:19 +0000)]
[packages] tmux: change dependency to libevent2

SVN-Revision: 27848

8 years ago[packages] tmux: update to 1.5
Jan Willies [Sun, 31 Jul 2011 15:19:51 +0000 (15:19 +0000)]
[packages] tmux: update to 1.5

SVN-Revision: 27847

8 years ago[packages] madwimax: fix detection for big endian systems
Jonas Gorski [Sun, 31 Jul 2011 12:46:00 +0000 (12:46 +0000)]
[packages] madwimax: fix detection for big endian systems

closes #7510.

SVN-Revision: 27845

8 years ago[packages] freeswitch: fix ZeroMQ download location
Jo-Philipp Wich [Sat, 30 Jul 2011 22:18:04 +0000 (22:18 +0000)]
[packages] freeswitch: fix ZeroMQ download location

SVN-Revision: 27842

8 years ago[packages] php5: fix dependencies for apc and sqlite3 (closes #9368)
Michael Heimpold [Sat, 30 Jul 2011 08:21:58 +0000 (08:21 +0000)]
[packages] php5: fix dependencies for apc and sqlite3 (closes #9368)

When using CONFIGURE_LIBS the php binary itself depends on these libs,
so the opkg depends also reflected this. But in this case it was
required to install those libs even when they were never planned to use.

SVN-Revision: 27839

8 years ago[packages] php5: PECL: include support for libevent
Michael Heimpold [Sat, 30 Jul 2011 06:38:53 +0000 (06:38 +0000)]
[packages] php5: PECL: include support for libevent

SVN-Revision: 27838

8 years ago[packages] php5: fix compile with older gcc
Michael Heimpold [Fri, 29 Jul 2011 21:59:03 +0000 (21:59 +0000)]
[packages] php5: fix compile with older gcc

This fix work around the membar_producer link error which
can be seen on backfire for brcm-2.4.

SVN-Revision: 27834

8 years ago[packages] irssi: use PKG_INSTALL, make headers available in staging_dir
Jo-Philipp Wich [Fri, 29 Jul 2011 12:40:09 +0000 (12:40 +0000)]
[packages] irssi: use PKG_INSTALL, make headers available in staging_dir

SVN-Revision: 27829

8 years ago[packages] php5: add PECL dio extension
Michael Heimpold [Wed, 27 Jul 2011 22:18:29 +0000 (22:18 +0000)]
[packages] php5: add PECL dio extension

SVN-Revision: 27802