firmware-utils: fix mistake and improve logic in nec-enc
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Sat, 31 Oct 2020 12:45:05 +0000 (21:45 +0900)
committerPetr Štetiar <ynezz@true.cz>
Thu, 12 Nov 2020 17:19:44 +0000 (18:19 +0100)
this patch fixes/improves follows:

- PATTERN_LEN is defined as a macro but unused
- redundant logic in count-up for "ptn"

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Makefile
src/nec-enc.c

index 7f1754a347dec64880574e556e72af4a6cc3a4fd..81c62d977a236fa67c3634a6e5a2fcd9be5c4523 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME := firmware-utils
-PKG_RELEASE := 4
+PKG_RELEASE := 5
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/kernel.mk
index 3c4e38721e2bc0b260393e78b89d2ccc92439b85..a2be3785868b8997f00fcde16e103a05bbeaa8d1 100644 (file)
@@ -47,7 +47,7 @@ static unsigned char buf_pattern[4096], buf[4096];
 
 int main(int argc, char **argv)
 {
-       int k_off = 0, ptn = 0, c, ret = EXIT_SUCCESS;
+       int k_off = 0, ptn = 1, c, ret = EXIT_SUCCESS;
        char *ifn = NULL, *ofn = NULL, *key = NULL;
        size_t n, k_len;
        FILE *out, *in;
@@ -99,11 +99,11 @@ int main(int argc, char **argv)
 
        while ((n = fread(buf, 1, sizeof(buf), in)) > 0) {
                for (int i = 0; i < n; i++) {
-                       buf_pattern[i] = ptn + 1;
+                       buf_pattern[i] = ptn;
                        ptn++;
 
-                       if (ptn > 250)
-                               ptn = 0;
+                       if (ptn > PATTERN_LEN)
+                               ptn = 1;
                }
 
                k_off = xor_pattern(buf_pattern, n, key, k_len, k_off);