cmake: fix missing install target
authorPetr Štetiar <ynezz@true.cz>
Mon, 5 Jul 2021 09:51:01 +0000 (11:51 +0200)
committerPetr Štetiar <ynezz@true.cz>
Mon, 5 Jul 2021 09:51:01 +0000 (11:51 +0200)
Add a missing install target so the binaries could be installed.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
CMakeLists.txt

index 0bcc448d3aed4970c1c0d03148330898c647366a..20feb6281cffde8de1b8d0aab3cd9059e5505adf 100644 (file)
@@ -17,6 +17,7 @@ ADD_DEFINITIONS(-Wall -Wno-unused-parameter)
 
 MACRO(FW_UTIL util deps extra_cflags libs)
   ADD_EXECUTABLE(${util} src/${util}.c ${deps})
+  INSTALL(TARGETS ${util} RUNTIME)
   IF(NOT ${ARGV2} STREQUAL "")
     SET_TARGET_PROPERTIES(${util} PROPERTIES COMPILE_FLAGS ${extra_cflags})
   ENDIF()