add a cmake file for the examples and add the binaries to .gitignore
authorFelix Fietkau <nbd@openwrt.org>
Sun, 21 Oct 2012 21:01:30 +0000 (23:01 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 21 Oct 2012 21:01:30 +0000 (23:01 +0200)
.gitignore
examples/CMakeLists.txt [new file with mode: 0644]

index 3308ef271466850518536cd64a9b9b924e623115..0c59f966c56503c8da154b046893af4fda16316a 100644 (file)
@@ -7,3 +7,4 @@ CMakeFiles
 *.dylib
 install_manifest.txt
 jshn
 *.dylib
 install_manifest.txt
 jshn
+*-example
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644 (file)
index 0000000..8727f35
--- /dev/null
@@ -0,0 +1,19 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(ubox-examples C)
+ADD_DEFINITIONS(-O1 -Wall -Werror --std=gnu99 -g3)
+
+IF(APPLE)
+  INCLUDE_DIRECTORIES(/opt/local/include)
+  LINK_DIRECTORIES(/opt/local/lib)
+ENDIF()
+
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
+LINK_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
+
+ADD_EXECUTABLE(blobmsg-example blobmsg-example.c)
+TARGET_LINK_LIBRARIES(blobmsg-example ubox blobmsg_json json)
+
+ADD_EXECUTABLE(ustream-example ustream-example.c)
+TARGET_LINK_LIBRARIES(ustream-example ubox)
+