* Disable Boa gunzip support
[project/luci.git] / Makefile
index 0e09682ae22bc57e6e3e815d039afcb310ff6c8b..38e2d155222f67ec039af64b963c58cae059011d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,10 @@
 include build/config.mk
 
-MODULES = applications/* libs/* modules/* themes/* i18n/*
+MODULES = applications/* libs/* modules/* themes/* i18n/* contrib/luaposix
 LUA_TARGET = source
 
-### luaposix merge (temporary) ###
 OS:=$(shell uname)
 export OS
-ifeq ($(OS),Darwin)
-  MODULES += contrib/luaposix
-endif
-
 
 .PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean
 
@@ -35,7 +30,7 @@ luahost: luabuild hostcopy
 
 hostcopy: 
        mkdir -p host
-       for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
+       for i in $(MODULES); do cp -a $$i/dist/* host/ -R 2>/dev/null || true; done
        rm -f host/luci
        ln -s .$(LUCI_INSTALLDIR) host/luci