Revert "* Updated Boa to 0.94.14rc21 + Debian patches"
[project/luci.git] / Makefile
index fa9a407303108e79771325151a829ff21afe718c..435d59c599b8f908a4cc179e83ac9598d5e8629d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -30,11 +30,12 @@ luahost: luabuild hostcopy
 
 hostcopy: 
        mkdir -p host
-       for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
+       for i in $(MODULES); do cp -a $$i/dist/* host/ -R 2>/dev/null || true; done
        rm -f host/luci
        ln -s .$(LUCI_INSTALLDIR) host/luci
 
 run: host
+       libs/sgi-webuci/host/buildconfig.sh `pwd`/host  > host/etc/boa/boa.conf
        ./host/usr/bin/boa -c ./host/etc/boa -d
 
 hostclean: clean