* Rewrote Luci to be coroutine-safe allowing the use of non-forking webservers
[project/luci.git] / Makefile
index 0e09682ae22bc57e6e3e815d039afcb310ff6c8b..796bb415412f5dea3ba988bb23fb3872b4566c38 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,10 @@
 include build/config.mk
 
-MODULES = applications/* libs/* modules/* themes/* i18n/*
+MODULES = applications/* libs/* modules/* themes/* i18n/* contrib/luaposix
 LUA_TARGET = source
 
-### luaposix merge (temporary) ###
 OS:=$(shell uname)
 export OS
-ifeq ($(OS),Darwin)
-  MODULES += contrib/luaposix
-endif
-
 
 .PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean
 
@@ -35,11 +30,12 @@ luahost: luabuild hostcopy
 
 hostcopy: 
        mkdir -p host
-       for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
+       for i in $(MODULES); do cp -a $$i/dist/* host/ -R 2>/dev/null || true; done
        rm -f host/luci
-       ln -s .$(LUCI_INSTALLDIR) host/luci
+       ln -s .$(LUCI_MODULEDIR) host/luci
 
 run: host
+       libs/sgi-webuci/host/buildconfig.sh `pwd`/host  > host/etc/boa/boa.conf
        ./host/usr/bin/boa -c ./host/etc/boa -d
 
 hostclean: clean