* Rewrote Luci to be coroutine-safe allowing the use of non-forking webservers
[project/luci.git] / Makefile
index c78f5a8108ae8c9fc36ef26917761a5f79133502..796bb415412f5dea3ba988bb23fb3872b4566c38 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,10 @@
 include build/config.mk
 
-MODULES = applications/* libs/* modules/* themes/* i18n/*
+MODULES = applications/* libs/* modules/* themes/* i18n/* contrib/luaposix
 LUA_TARGET = source
 
-### luaposix merge (temporary) ###
 OS:=$(shell uname)
 export OS
-ifeq ($(OS),Darwin)
-  MODULES += contrib/luaposix
-endif
-
 
 .PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean
 
@@ -35,8 +30,13 @@ luahost: luabuild hostcopy
 
 hostcopy: 
        mkdir -p host
-       for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
-       ln -sf .$(LUCI_INSTALLDIR) host/luci
-       
+       for i in $(MODULES); do cp -a $$i/dist/* host/ -R 2>/dev/null || true; done
+       rm -f host/luci
+       ln -s .$(LUCI_MODULEDIR) host/luci
+
+run: host
+       libs/sgi-webuci/host/buildconfig.sh `pwd`/host  > host/etc/boa/boa.conf
+       ./host/usr/bin/boa -c ./host/etc/boa -d
+
 hostclean: clean
        rm -rf host