applications/luci-splash: Added UCI-state based server address detection
[project/luci.git] / Makefile
index 32ef02d4e5c043409120b01cd0d8a9b49c460e82..8ac0ac664ad48c63df18044b081e194d068b9b43 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,22 +1,56 @@
 include build/config.mk
 
-MODULES = applications/* core modules/* themes/*
+MODULES = applications/* libs/* modules/* themes/* i18n/* contrib/luaposix
 LUA_TARGET = source
 
+OS:=$(shell uname)
+export OS
 
-.PHONY: all build clean host hostclean
+.PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean
 
 all: build
 
-build:
-       for i in $(MODULES); do make -C$$i $(LUA_TARGET); done
+build: luabuild gccbuild
+
+gccbuild:
+       for i in $(MODULES); do make -C$$i compile; done        
+
+luabuild:
+       for i in $(MODULES); do make -C$$i lua$(LUA_TARGET); done
 
 clean:
        for i in $(MODULES); do make -C$$i clean; done
 
-host: build
-       mkdir -p host/luci
-       for i in $(MODULES); do cp $$i/dist$(LUCI_INSTALLDIR) host/ -R 2>/dev/null || true; done
-       
+
+host: build hostcopy
+
+gcchost: gccbuild hostcopy
+
+luahost: luabuild hostcopy
+
+hostcopy: 
+       mkdir -p host
+       for i in $(MODULES); do cp -a $$i/dist/* host/ -R 2>/dev/null || true; done
+       rm -f host/luci
+       ln -s .$(LUCI_MODULEDIR) host/luci
+
+runboa: host
+       export LUA_PATH="`pwd`/host$(LUCI_MODULEDIR);;"
+       export LUA_CPATH="`pwd`/host$(LUCI_LIBRARYDIR);;"
+       libs/sgi-webuci/host/buildconfig.sh `pwd`/host  > host/etc/boa/boa.conf
+       ./host/usr/bin/boa -c ./host/etc/boa -d
+
+runluci: luahost
+       export LUA_PATH="`pwd`/host$(LUCI_MODULEDIR);;"
+       export LUA_CPATH="`pwd`/host$(LUCI_LIBRARYDIR);;"
+       libs/httpd/host/runluci host$(HTDOCS)
+
 hostclean: clean
-       rm host -rf
+       rm -rf host
+
+run:
+       #       make run is deprecated                  #
+       #       Please use:                             #
+       #                                               #
+       #       make runluci to use LuCI HTTPD          #
+       #       make runboa  to use Boa / Webuci        #