modules/admin-mini: Add "general" submenu links
[project/luci.git] / Makefile
index fa9a407303108e79771325151a829ff21afe718c..8ac0ac664ad48c63df18044b081e194d068b9b43 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -30,12 +30,27 @@ luahost: luabuild hostcopy
 
 hostcopy: 
        mkdir -p host
 
 hostcopy: 
        mkdir -p host
-       for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
+       for i in $(MODULES); do cp -a $$i/dist/* host/ -R 2>/dev/null || true; done
        rm -f host/luci
        rm -f host/luci
-       ln -s .$(LUCI_INSTALLDIR) host/luci
+       ln -s .$(LUCI_MODULEDIR) host/luci
 
 
-run: host
+runboa: host
+       export LUA_PATH="`pwd`/host$(LUCI_MODULEDIR);;"
+       export LUA_CPATH="`pwd`/host$(LUCI_LIBRARYDIR);;"
+       libs/sgi-webuci/host/buildconfig.sh `pwd`/host  > host/etc/boa/boa.conf
        ./host/usr/bin/boa -c ./host/etc/boa -d
 
        ./host/usr/bin/boa -c ./host/etc/boa -d
 
+runluci: luahost
+       export LUA_PATH="`pwd`/host$(LUCI_MODULEDIR);;"
+       export LUA_CPATH="`pwd`/host$(LUCI_LIBRARYDIR);;"
+       libs/httpd/host/runluci host$(HTDOCS)
+
 hostclean: clean
        rm -rf host
 hostclean: clean
        rm -rf host
+
+run:
+       #       make run is deprecated                  #
+       #       Please use:                             #
+       #                                               #
+       #       make runluci to use LuCI HTTPD          #
+       #       make runboa  to use Boa / Webuci        #