Squashed commit of the following:
[project/luci.git] / Makefile
index 4b3fb64f4b7bc8712f650be789212fa83a4b9055..d76be9a2de8b0b8b5838a7a4d4a738fca348bed0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,12 @@
 include build/config.mk
 
 MODULES = applications/* libs/* modules/* themes/* i18n/*
 include build/config.mk
 
 MODULES = applications/* libs/* modules/* themes/* i18n/*
-LUA_TARGET = source
-
+LUA_TARGET = compile
+OS:=$(shell uname)
+export OS
+ifeq ($(OS),Darwin)
+  MODULES += contrib/luaposix
+endif
 
 .PHONY: all build clean host hostclean
 
 
 .PHONY: all build clean host hostclean