Commit from LuCI Translation Portal by user jow.: 42 of 43 messages translated (0...
[project/luci.git] / Makefile
index ceb80ac249dcd172ff50699fef2888386344ed59..efccd79d09d67b69dfd8d659bd35483b4f88f51f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -3,6 +3,8 @@ include build/config.mk
 MODULES = contrib/* applications/* libs/* modules/* themes/* i18n/*
 
 OS:=$(shell uname)
+MODULES:=$(foreach item,$(wildcard $(MODULES)),$(if $(realpath $(wildcard $(item)/Makefile)),$(item)))
+
 export OS
 
 .PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean
@@ -77,9 +79,8 @@ hostclean: clean
 apidocs: hostenv
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh host/luci/ docs"
 
-uvldocs: hostenv
-       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) \
-       "build/uvldoc $(realpath host) $(UVL_SCHEMEDIR) uvldocs $(DOCS)"
+nixiodocs: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh libs/nixio/ nixiodocs"
 
 po: host
        for L in $${LANGUAGE:-$$(find i18n/ -path 'i18n/*/luasrc/i18n/*' -name 'default.*.lua' | \