some error handling for fs.dir(...) == nil
[project/luci.git] / Makefile
index c78f5a8108ae8c9fc36ef26917761a5f79133502..fa9a407303108e79771325151a829ff21afe718c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,10 @@
 include build/config.mk
 
-MODULES = applications/* libs/* modules/* themes/* i18n/*
+MODULES = applications/* libs/* modules/* themes/* i18n/* contrib/luaposix
 LUA_TARGET = source
 
-### luaposix merge (temporary) ###
 OS:=$(shell uname)
 export OS
-ifeq ($(OS),Darwin)
-  MODULES += contrib/luaposix
-endif
-
 
 .PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean
 
@@ -36,7 +31,11 @@ luahost: luabuild hostcopy
 hostcopy: 
        mkdir -p host
        for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
-       ln -sf .$(LUCI_INSTALLDIR) host/luci
-       
+       rm -f host/luci
+       ln -s .$(LUCI_INSTALLDIR) host/luci
+
+run: host
+       ./host/usr/bin/boa -c ./host/etc/boa -d
+
 hostclean: clean
        rm -rf host