Add luci-theme-freifunk-generic
[project/luci.git] / contrib / package / luci / Makefile
index 617088750b9681ae31b956e9f35489397b1397e8..07f0bcd90699c55861eb4c64ce0651b826357961 100644 (file)
@@ -459,7 +459,7 @@ define theme
     SUBMENU:=Themes
     TITLE:=$(if $(2),$(2),LuCI $(1) theme)
        MAINTAINER:=$(if $(3),$(3),LuCI Development Team <luci@lists.subsignal.org>)
-       DEPENDS:=$(ifneq $(1),base,+luci-theme-base) $(4)
+       DEPENDS:=$(if $(filter-out base,$(1)),+luci-theme-base) $(4)
        $(if $(5),DEFAULT:=y if PACKAGE_luci-lib-core)
   endef
 
@@ -476,7 +476,6 @@ endef
 
 $(eval $(call theme,base,Common base for all themes,,+luci-lib-web))
 $(eval $(call theme,openwrt,OpenWrt.org (default),,,1))
-$(eval $(call theme,openwrt-light,OpenWrt.org - light variant without images))
 $(eval $(call theme,fledermaus,Fledermaus Theme))
 
 $(eval $(call theme,freifunk,alternative Freifunk Theme,\
@@ -488,6 +487,8 @@ $(eval $(call theme,freifunk-bno,Freifunk Berlin Nordost Theme,\
 $(eval $(call theme,freifunk-hannover,Freifunk Hannover Theme,\
        Mikolas Bingemer <mickey-at-freifunk-hannover-dot-de>))
 
+$(eval $(call theme,freifunk-generic,Freifunk Generic Theme,\
+        Manuel Munz <freifunk-at-somakoma-dot-de>))
 
 ### Translations ###
 define translation
@@ -550,20 +551,16 @@ endef
 
 $(eval $(call collection,,\
        Standard OpenWrt set including full and mini admin and the standard theme,\
-       +uhttpd +luci-mod-admin-full +luci-mod-admin-mini +luci-theme-openwrt \
-    +luci-app-firewall +luci-app-initmgr))
+       +uhttpd +luci-mod-admin-full +luci-theme-openwrt +luci-app-firewall \
+       +luci-app-initmgr))
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
-       +uhttpd +uhttpd-mod-tls +px5g +luci-mod-admin-full +luci-mod-admin-mini \
-    +luci-theme-openwrt +luci-app-firewall +luci-app-initmgr))
-
-$(eval $(call collection,medium,\
-       Medium package set using only admin full and a theme without graphics,\
-       +uhttpd +luci-mod-admin-full +luci-theme-openwrt-light))
+       +uhttpd +uhttpd-mod-tls +px5g +luci-mod-admin-full +luci-theme-openwrt \
+       +luci-app-firewall +luci-app-initmgr))
 
 $(eval $(call collection,light,\
-       Minimum package set using only admin mini and a theme without graphics,\
+       Minimum package set using only admin mini and the standard theme,\
        +uhttpd +luci-mod-admin-mini +luci-theme-openwrt-light))