add language packages for portuguese and catalan
[project/luci.git] / contrib / package / luci / Makefile
index c2f7fa62180cade8ab135b3d4dd729f9f9f93471..2e7e7a567b32da8e5587d49bdb75cb4d2c03ffe2 100644 (file)
@@ -227,7 +227,7 @@ define Package/luci-luanet
 endef
 
 define Package/luci-luanet/install
-        $(call Package/luci/install/template,$(1),libs/luanet)
+       $(call Package/luci/install/template,$(1),libs/luanet)
 endef
 
 
@@ -238,8 +238,8 @@ define Package/luci-lucid
 endef
 
 define Package/luci-lucid/install
-        $(call Package/luci/install/template,$(1),libs/lucid)
-        $(call Package/luci/install/template,$(1),libs/lucid-http)
+       $(call Package/luci/install/template,$(1),libs/lucid)
+       $(call Package/luci/install/template,$(1),libs/lucid-http)
 endef
 
 
@@ -289,7 +289,7 @@ endef
 
 define Package/luci-web
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-http +luci-sys +luci-uci +luci-lucid
+  DEPENDS+=+luci-http +luci-sys +luci-uci +luci-lucid +luci-sgi-cgi
   TITLE:=MVC Webframework
   $(call Config,luci.main.lang,string,en,Default Language)
 endef
@@ -334,7 +334,7 @@ endef
 define Package/luci-freifunk-community
   $(call Package/luci/fftemplate)
   DEPENDS+= \
-   +luci-lucid +luci-app-splash \
+   +luci-lucid +luci-sgi-cgi +luci-app-splash \
    +luci-app-ffwizard-leipzig \
    +luci-i18n-german \
    +PACKAGE_luci-freifunk-community:olsrd-luci +PACKAGE_luci-freifunk-community:olsrd-luci-mod-dyn-gw-plain \
@@ -831,6 +831,27 @@ define Package/luci-i18n-greek/install
        $(call Package/luci/install/template,$(1),i18n/greek)
 endef
 
+
+define Package/luci-i18n-catalan
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Catalan (by Eduard Duran)
+endef
+
+define Package/luci-i18n-catalan/install
+       $(call Package/luci/install/template,$(1),i18n/catalan)
+endef
+
+
+define Package/luci-i18n-portuguese
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Portuguese (by Jose Monteiro)
+endef
+
+define Package/luci-i18n-portuguese/install
+       $(call Package/luci/install/template,$(1),i18n/portuguese)
+endef
+
+
 ### Compile ###
 ifneq ($(CONFIG_PACKAGE_luci-core),)
        PKG_SELECTED_MODULES+=libs/core
@@ -1023,6 +1044,12 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-greek),)
        PKG_SELECTED_MODULES+=i18n/greek
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-catalan),)
+       PKG_SELECTED_MODULES+=i18n/catalan
+endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-portuguese),)
+       PKG_SELECTED_MODULES+=i18n/portuguese
+endif
 
 
 MAKE_FLAGS += \
@@ -1100,3 +1127,5 @@ $(eval $(call BuildPackage,luci-i18n-russian))
 $(eval $(call BuildPackage,luci-i18n-portuguese_brazilian))
 $(eval $(call BuildPackage,luci-i18n-japanese))
 $(eval $(call BuildPackage,luci-i18n-greek))
+$(eval $(call BuildPackage,luci-i18n-catalan))
+$(eval $(call BuildPackage,luci-i18n-portuguese))