luci: add greek translation, thanks Vasilis Tsiligiannis!
[project/luci.git] / contrib / package / luci / Makefile
index 044eca6aef1919bb0b4aeb365757d0bcbdba6c6b..5795b4da32681e81ac85fb0b9d03dc4e2c34b39b 100644 (file)
@@ -127,6 +127,9 @@ define Package/luci-core/config
        config PACKAGE_luci-core_source
                bool "Full Source"
 
+       config PACKAGE_luci-core_zipped
+               bool "Precompiled and compressed"
+
        endchoice
 endef
 
@@ -138,6 +141,10 @@ ifneq ($(CONFIG_PACKAGE_luci-core_stripped),)
   LUA_TARGET:=strip
 endif
 
+ifneq ($(CONFIG_PACKAGE_luci-core_zipped),)
+  LUA_TARGET:=gzip
+endif
+
 
 ### Libraries ###
 define Package/luci-cbi
@@ -333,7 +340,7 @@ endef
 
 define Package/luci-admin-core
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-web +luci-cbi +luci-theme-openwrt +luci-i18n-english
+  DEPENDS+=+luci-web +luci-cbi +luci-i18n-english
   TITLE:=Web UI Core Module
 endef
 
@@ -810,6 +817,16 @@ define Package/luci-i18n-japanese/install
        $(call Package/luci/install/template,$(1),i18n/japanese)
 endef
 
+
+define Package/luci-i18n-greek
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Greek (by Vasilis Tsiligiannis)
+endef
+
+define Package/luci-i18n-greek/install
+       $(call Package/luci/install/template,$(1),i18n/greek)
+endef
+
 ### Compile ###
 ifneq ($(CONFIG_PACKAGE_luci-core),)
        PKG_SELECTED_MODULES+=libs/core
@@ -993,6 +1010,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-japanese),)
        PKG_SELECTED_MODULES+=i18n/japanese
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-greek),)
+       PKG_SELECTED_MODULES+=i18n/greek
+endif
 
 
 MAKE_FLAGS += \
@@ -1069,3 +1089,4 @@ $(eval $(call BuildPackage,luci-i18n-italian))
 $(eval $(call BuildPackage,luci-i18n-russian))
 $(eval $(call BuildPackage,luci-i18n-portuguese_brazilian))
 $(eval $(call BuildPackage,luci-i18n-japanese))
+$(eval $(call BuildPackage,luci-i18n-greek))