* Rolling back to Boa 0.94.13 due to chaos
[project/luci.git] / contrib / package / luci / Makefile
index 427fb20cfb6bd55c1dee752043ec512b4f2643f1..af662f8cb36f75ca6ee1c03c8a8f3b9b77816ac3 100644 (file)
@@ -5,7 +5,7 @@ PKG_SOURCE_URL:=https://dev.leipzig.freifunk.net/svn/ff-luci/$(PKG_BRANCH)
 PKG_REV:=$(shell LC_ALL=C svn info ${PKG_SOURCE_URL} | sed -ne's/^Last Changed Rev: //p')
 
 PKG_NAME:=luci
-PKG_VERSION:=0.5+svn$(PKG_REV)
+PKG_VERSION:=0.6+svn$(PKG_REV)
 PKG_RELEASE:=1
 
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -62,7 +62,8 @@ endef
 
 
 define Package/luci/install/template
-       $(CP) $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
+       $(CP) -a $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
+       $(CP) -a $(PKG_BUILD_DIR)/$(2)/ipkg/* $(1)/CONTROL/ 2>/dev/null || true
 endef
 
 
@@ -110,6 +111,17 @@ define Package/luci-cbi/install
 endef
 
 
+define Package/luci-uci
+  $(call Package/luci/libtemplate)
+  DEPENDS+=+libuci-lua
+  TITLE:=High-Level UCI API
+endef
+
+define Package/luci-uci/install
+       $(call Package/luci/install/template,$(1),libs/uci)
+endef
+
+
 define Package/luci-fastindex
   $(call Package/luci/libtemplate)
   TITLE:=Fastindex indexing module
@@ -122,7 +134,7 @@ endef
 
 define Package/luci-web
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-addons
+  DEPENDS+=+luci-addons +luci-uci
   TITLE:=MVC Webframework
 endef
 
@@ -141,7 +153,7 @@ endef
 define Package/luci-ff-halle
   $(call Package/luci/fftemplate)
   DEPENDS+= \
-   +luci-sgi-haserl +luci-app-splash \
+   +luci-sgi-haserl +luci-app-splash +luci-app-olsr \
    +luci-app-ffwizard-leipzig \
    +luci-theme-fledermaus \
    +luci-i18n-german \
@@ -152,14 +164,13 @@ endef
 
 define Package/luci-ff-halle/install
        $(call Package/luci/install/template,$(1),applications/community-halle)
-       $(CP) -a ./ipkg/luci-ff-halle.postinst $(1)/CONTROL/postinst
 endef
 
 
 define Package/luci-ff-leipzig
   $(call Package/luci/fftemplate)
   DEPENDS+= \
-   +luci-sgi-haserl +luci-app-splash \
+   +luci-sgi-haserl +luci-app-splash +luci-app-olsr \
    +luci-app-ffwizard-leipzig \
    +luci-theme-fledermaus \
    +luci-i18n-german \
@@ -170,14 +181,13 @@ endef
 
 define Package/luci-ff-leipzig/install
        $(call Package/luci/install/template,$(1),applications/community-leipzig)
-       $(CP) -a ./ipkg/luci-ff-leipzig.postinst $(1)/CONTROL/postinst
 endef
 
 
 define Package/luci-ff-hannover
   $(call Package/luci/fftemplate)
   DEPENDS+= \
-   +luci-sgi-haserl +luci-app-splash \
+   +luci-sgi-haserl +luci-app-splash +luci-app-olsr \
    +luci-theme-fledermaus \
    +luci-i18n-german \
    +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
@@ -188,7 +198,6 @@ endef
 
 define Package/luci-ff-hannover/install
        $(call Package/luci/install/template,$(1),applications/community-hannover)
-       $(CP) -a ./ipkg/luci-ff-hannover.postinst $(1)/CONTROL/postinst
 endef
 
 
@@ -246,13 +255,34 @@ endef
 
 define Package/luci-app-firewall/install
        $(call Package/luci/install/template,$(1),applications/luci-fw)
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-fw/dist/etc/init.d/luci_fw $(1)/etc/init.d
+endef
+
+
+define Package/luci-app-olsr
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-mod-admin-core +olsrd-mod-txtinfo
+  TITLE:=OLSR configuration and status module
+endef
+
+define Package/luci-app-olsr/install
+       $(call Package/luci/install/template,$(1),applications/luci-olsr)
+endef
+
+
+define Package/luci-app-qos
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-mod-admin-core +qos-scripts
+  TITLE:=Quality of Service configuration module
+endef
+
+define Package/luci-app-qos/install
+       $(call Package/luci/install/template,$(1),applications/luci-qos)
 endef
 
 
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
-  DEPENDS+=+luci-sgi-haserl +iptables-mod-nat +iptables-mod-ipopt
+  DEPENDS+=+iptables-mod-nat +iptables-mod-ipopt
   TITLE:=Freifunk DHCP-Splash application
 endef
 
@@ -262,18 +292,13 @@ endef
 
 define Package/luci-app-splash/install
        $(call Package/luci/install/template,$(1),applications/luci-splash)
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/usr/sbin/luci-splash $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/etc/init.d/luci_splash $(1)/etc/init.d
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/etc/cron.minutely/luci_splash $(1)/etc/cron.minutely
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi $(1)/usr/lib/luci-splash/htdocs/cgi-bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/www/cgi-bin/luci-splash $(1)/www/cgi-bin/luci-splash
 endef
 
 
 define Package/luci-app-statistics
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-mod-admin-core +collectd +collectd-mod-rrdtool1 +rrdtool1
-  TITLE:=LuCI Statistics Application (incomplete)
+  TITLE:=LuCI Statistics Application
 endef
 
 define Package/luci-app-statistics/conffiles
@@ -282,8 +307,6 @@ endef
 
 define Package/luci-app-statistics/install
        $(call Package/luci/install/template,$(1),applications/luci-statistics)
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/usr/bin/stat-genconfig $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/etc/init.d/luci_statistics $(1)/etc/init.d
 endef
 
 
@@ -297,7 +320,6 @@ endef
 
 define Package/luci-sgi-haserl/install
        $(call Package/luci/install/template,$(1),libs/sgi-haserl)
-       $(CP) -a ./ipkg/luci-sgi-haserl.postinst $(1)/CONTROL/postinst
 endef
 
 
@@ -363,6 +385,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-fastindex),)
        PKG_SELECTED_MODULES+=libs/fastindex
 endif
+ifneq ($(CONFIG_PACKAGE_luci-uci),)
+       PKG_SELECTED_MODULES+=libs/uci
+endif
 ifneq ($(CONFIG_PACKAGE_luci-web),)
        PKG_SELECTED_MODULES+=libs/web
 endif
@@ -390,6 +415,12 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-firewall),)
        PKG_SELECTED_MODULES+=applications/luci-fw
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-olsr),)
+       PKG_SELECTED_MODULES+=applications/luci-olsr
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-qos),)
+       PKG_SELECTED_MODULES+=applications/luci-qos
+endif
 ifneq ($(CONFIG_PACKAGE_luci-app-splash),)
        PKG_SELECTED_MODULES+=applications/luci-splash
 endif
@@ -425,6 +456,7 @@ MAKE_FLAGS += MODULES="$(PKG_SELECTED_MODULES)" LUA_TARGET="$(LUA_TARGET)" CFLAG
 $(eval $(call BuildPackage,luci-core))
 $(eval $(call BuildPackage,luci-cbi))
 $(eval $(call BuildPackage,luci-fastindex))
+$(eval $(call BuildPackage,luci-uci))
 $(eval $(call BuildPackage,luci-web))
 
 $(eval $(call BuildPackage,luci-ff-halle))
@@ -436,6 +468,8 @@ $(eval $(call BuildPackage,luci-mod-freifunk))
 
 $(eval $(call BuildPackage,luci-app-ffwizard-leipzig))
 $(eval $(call BuildPackage,luci-app-firewall))
+$(eval $(call BuildPackage,luci-app-olsr))
+$(eval $(call BuildPackage,luci-app-qos))
 $(eval $(call BuildPackage,luci-app-splash))
 $(eval $(call BuildPackage,luci-app-statistics))