libs/json: Completed JSON library
[project/luci.git] / contrib / package / luci / Makefile
index 8ae97fcf15fa63ed96ebe9d2d9c043cea9b649c9..e8a1d3698d39cf1539f4e2c414219046287fce92 100644 (file)
@@ -12,7 +12,7 @@ PKG_RELEASE:=1
 ifeq ($(USELOCAL),1)
   PKG_VERSION:=0.7+svn
 else
-  PKG_SOURCE_URL:=https://dev.leipzig.freifunk.net/svn/ff-luci/$(PKG_BRANCH)
+  PKG_SOURCE_URL:=http://dev.leipzig.freifunk.net/svn/ff-luci/$(PKG_BRANCH)
   ifeq ($(DUMP),)
     PKG_REV:=$(shell LC_ALL=C svn info ${PKG_SOURCE_URL} | sed -ne's/^Last Changed Rev: //p')
     PKG_VERSION:=0.7+svn$(PKG_REV)
@@ -55,37 +55,37 @@ define Package/luci/libtemplate
   TITLE:=LuCI - Lua Configuration Interface
   URL:=http://luci.freifunk-halle.net/
   MAINTAINER:=Steven Barth <steven-at-midlink-dot-org>
-  SUBMENU:=LuCI Libraries
+  SUBMENU:=LuCI Libraries
   DEPENDS:=+luci-core
 endef
 
 define Package/luci/fftemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI - Freifunk Support (GERMAN ONLY)
-  DEPENDS:=+luci-mod-freifunk
+  SUBMENU:=LuCI Freifunk Support (PARTLY BROKEN)
+  DEPENDS:=+luci-mod-freifunk @BROKEN
 endef
 
 define Package/luci/httpdtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Non-Forking HTTP-Daemon (EXPERIMENTAL)
+  SUBMENU:=LuCI Non-Forking HTTP-Daemon (EXPERIMENTAL)
   DEPENDS:=+luci-httpd
 endef
 
 define Package/luci/i18ntemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Translations
+  SUBMENU:=LuCI Translations
   DEPENDS:=+luci-web
 endef
 
 define Package/luci/thtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Themes
+  SUBMENU:=LuCI Themes
   DEPENDS:=+luci-web
 endef
 
 define Package/luci/webtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI - Webinterface Components
+  SUBMENU:=LuCI Components
 endef
 
 
@@ -100,24 +100,27 @@ endef
 
 define Package/luci-core
   $(call Package/luci/libtemplate)
-  DEPENDS:=+lua +luaposix
+  DEPENDS:=+lua +luaposix +bitlib
   TITLE:=LuCI core libraries
 endef
 
-define Package/luci-core/install               
+define Package/luci-core/install
        $(call Package/luci/install/template,$(1),libs/core)
 endef
 
 define Package/luci-core/config
        choice
                prompt "Build Target"
-               default PACKAGE_luci-core_compile
+               default PACKAGE_luci-core_source
 
        config PACKAGE_luci-core_compile
-               bool "Production"
+               bool "Precompiled"
+
+       config PACKAGE_luci-core_stripped
+               bool "Stripped"
 
        config PACKAGE_luci-core_source
-               bool "Debug"
+               bool "Full Source"
 
        endchoice
 endef
@@ -126,11 +129,15 @@ ifneq ($(CONFIG_PACKAGE_luci-core_compile),)
   LUA_TARGET:=compile
 endif
 
+ifneq ($(CONFIG_PACKAGE_luci-core_stripped),)
+  LUA_TARGET:=strip
+endif
+
 
 ### Libraries ###
 define Package/luci-cbi
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web
+  DEPENDS+=+luci-web +luci-uvl +luci-uci
   TITLE:=Configuration Binding Interface
 endef
 
@@ -170,9 +177,39 @@ define Package/luci-http/install
 endef
 
 
+define Package/luci-ipkg
+  $(call Package/luci/libtemplate)
+  TITLE:=LuCI IPKG/OPKG call abstraction library
+endef
+
+define Package/luci-ipkg/install
+       $(call Package/luci/install/template,$(1),libs/ipkg)
+endef
+
+
+define Package/luci-json
+  $(call Package/luci/libtemplate)
+  TITLE:=LuCI JSON Library
+endef
+
+define Package/luci-json/install
+       $(call Package/luci/install/template,$(1),libs/json)
+endef
+
+
+define Package/luci-sys
+  $(call Package/luci/libtemplate)
+  TITLE:=LuCI Linux/POSIX system library
+endef
+
+define Package/luci-sys/install
+       $(call Package/luci/install/template,$(1),libs/sys)
+endef
+
+
 define Package/luci-web
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-http +luci-addons +luci-uci +luci-sgi-cgi
+  DEPENDS+=+luci-http +luci-sys +luci-addons +luci-uci +luci-sgi-cgi
   TITLE:=MVC Webframework
 endef
 
@@ -185,6 +222,17 @@ define Package/luci-web/install
 endef
 
 
+define Package/luci-uvl
+  $(call Package/luci/libtemplate)
+  DEPENDS+=+luci-sys +luci-uci +luci-core
+  TITLE:=UVL - UCI Validation Layer
+endef
+
+define Package/luci-uvl/install
+       $(call Package/luci/install/template,$(1),libs/uvl)
+endef
+
+
 
 ### HTTPD ###
 
@@ -283,42 +331,53 @@ endef
 
 ### Modules ###
 
-define Package/luci-mod-admin-core
+define Package/luci-admin-core
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-web +luci-cbi +luci-theme-openwrt +luci-i18n-english
-  TITLE:=Administration core module
+  TITLE:=Web UI Core Module
 endef
 
-define Package/luci-mod-admin-core/install
+define Package/luci-admin-core/install
        $(call Package/luci/install/template,$(1),modules/admin-core)
 endef
 
 
-define Package/luci-mod-admin-mini
+define Package/luci-admin-mini
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-core
-  TITLE:=Simplified Administration module (INCOMPLETE)
+  DEPENDS+=+luci-admin-core
+  TITLE:=LuCI Essentials - casual user's interface
 endef
 
-define Package/luci-mod-admin-mini/install
+define Package/luci-admin-mini/install
        $(call Package/luci/install/template,$(1),modules/admin-mini)
 endef
 
 
-define Package/luci-mod-admin-full
+define Package/luci-admin-full
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-core
-  TITLE:=Full featured Administration module
+  DEPENDS+=+luci-admin-core +luci-ipkg
+  TITLE:=LuCI Administration - power user's interface
 endef
 
-define Package/luci-mod-admin-full/install
+define Package/luci-admin-full/install
        $(call Package/luci/install/template,$(1),modules/admin-full)
 endef
 
 
+define Package/luci-admin-rpc
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-json
+  TITLE:=LuCI RPC - JSON-RPC API
+endef
+
+define Package/luci-admin-rpc/install
+       $(call Package/luci/install/template,$(1),modules/rpc)
+endef
+
+
 define Package/luci-mod-freifunk
   $(call Package/luci/fftemplate)
-  DEPENDS:=+luci-mod-admin-full
+  DEPENDS:=+luci-admin-full
   TITLE:=LuCI Freifunk module
 endef
 
@@ -336,7 +395,6 @@ endef
 
 define Package/luci-app-ffwizard-leipzig
   $(call Package/luci/fftemplate)
-  DEPENDS+=+luci-app-firewall
   TITLE:=Freifunk Leipzig configuration wizard
 endef
 
@@ -347,14 +405,10 @@ endef
 
 define Package/luci-app-firewall
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-core
+  DEPENDS+=+luci-admin-core
   TITLE:=Firewall and Portforwarding application
 endef
 
-define Package/luci-app-firewall/conffiles
-/etc/config/luci_fw
-endef
-
 define Package/luci-app-firewall/install
        $(call Package/luci/install/template,$(1),applications/luci-fw)
 endef
@@ -362,7 +416,7 @@ endef
 
 define Package/luci-app-olsr
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-full +olsrd-mod-txtinfo
+  DEPENDS+=+luci-admin-full +olsrd +olsrd-mod-txtinfo
   TITLE:=OLSR configuration and status module
 endef
 
@@ -373,7 +427,7 @@ endef
 
 define Package/luci-app-qos
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-core +qos-scripts
+  DEPENDS+=+luci-admin-core +qos-scripts
   TITLE:=Quality of Service configuration module
 endef
 
@@ -384,7 +438,7 @@ endef
 
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
-  DEPENDS+=+luasocket +iptables-mod-nat +iptables-mod-ipopt
+  DEPENDS+=+luasocket
   TITLE:=Freifunk DHCP-Splash application
 endef
 
@@ -399,7 +453,7 @@ endef
 
 define Package/luci-app-statistics
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-full +collectd +collectd-mod-rrdtool1 +rrdtool1
+  DEPENDS+=+luci-admin-full +collectd +collectd-mod-rrdtool1 +rrdtool1
   TITLE:=LuCI Statistics Application
 endef
 
@@ -412,6 +466,50 @@ define Package/luci-app-statistics/install
 endef
 
 
+define Package/luci-app-upnp
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-core +miniupnpd
+  TITLE:=Universal Plug & Play configuration module
+endef
+
+define Package/luci-app-upnp/install
+       $(call Package/luci/install/template,$(1),applications/luci-upnp)
+endef
+
+
+define Package/luci-app-ntpc
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-core +ntpclient
+  TITLE:=NTP time synchronisation client configuration module
+endef
+
+define Package/luci-app-ntpc/install
+       $(call Package/luci/install/template,$(1),applications/luci-ntpc)
+endef
+
+
+define Package/luci-app-ddns
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-core +ddns-scripts
+  TITLE:=Dynamic DNS configuration module
+endef
+
+define Package/luci-app-ddns/install
+       $(call Package/luci/install/template,$(1),applications/luci-ddns)
+endef
+
+
+define Package/luci-app-samba
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +samba3
+  TITLE:=Network Shares - Samba SMB/CIFS module
+endef
+
+define Package/luci-app-samba/install
+       $(call Package/luci/install/template,$(1),applications/luci-samba)
+endef
+
+
 ### Server Gateway Interfaces ###
 
 define Package/luci-sgi-cgi
@@ -462,6 +560,16 @@ define Package/luci-theme-openwrt/install
        $(call Package/luci/install/template,$(1),themes/openwrt.org)
 endef
 
+define Package/luci-theme-openwrtlight
+  $(call Package/luci/thtemplate)
+  TITLE:=OpenWRT.org - light variant without images
+endef
+
+define Package/luci-theme-openwrtlight/install
+       $(call Package/luci/install/template,$(1),themes/openwrt-light)
+endef
+
+
 ### Translations ###
 define Package/luci-i18n-german
   $(call Package/luci/i18ntemplate)
@@ -485,7 +593,7 @@ endef
 
 define Package/luci-i18n-french
   $(call Package/luci/i18ntemplate)
-  TITLE:=French
+  TITLE:=French (by Florian Fainelli)
 endef
 
 define Package/luci-i18n-french/install
@@ -493,6 +601,15 @@ define Package/luci-i18n-french/install
 endef
 
 
+define Package/luci-i18n-russian
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Russian (by Skryabin Dmitry)
+endef
+
+define Package/luci-i18n-russian/install
+       $(call Package/luci/install/template,$(1),i18n/russian)
+endef
+
 
 
 ### Compile ###
@@ -508,12 +625,24 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-http),)
        PKG_SELECTED_MODULES+=libs/http
 endif
+ifneq ($(CONFIG_PACKAGE_luci-ipkg),)
+       PKG_SELECTED_MODULES+=libs/ipkg
+endif
+ifneq ($(CONFIG_PACKAGE_luci-json),)
+       PKG_SELECTED_MODULES+=libs/json
+endif
 ifneq ($(CONFIG_PACKAGE_luci-uci),)
        PKG_SELECTED_MODULES+=libs/uci
 endif
+ifneq ($(CONFIG_PACKAGE_luci-sys),)
+       PKG_SELECTED_MODULES+=libs/sys
+endif
 ifneq ($(CONFIG_PACKAGE_luci-web),)
        PKG_SELECTED_MODULES+=libs/web
 endif
+ifneq ($(CONFIG_PACKAGE_luci-uvl),)
+       PKG_SELECTED_MODULES+=libs/uvl
+endif
 
 ifneq ($(CONFIG_PACKAGE_luci-httpd),)
        PKG_SELECTED_MODULES+=libs/httpd
@@ -535,15 +664,18 @@ ifneq ($(CONFIG_PACKAGE_luci-ff-augsburg),)
         PKG_SELECTED_MODULES+=applications/community-augsburg
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-mod-admin-core),)
+ifneq ($(CONFIG_PACKAGE_luci-admin-core),)
        PKG_SELECTED_MODULES+=modules/admin-core
 endif
-ifneq ($(CONFIG_PACKAGE_luci-mod-admin-mini),)
+ifneq ($(CONFIG_PACKAGE_luci-admin-mini),)
        PKG_SELECTED_MODULES+=modules/admin-mini
 endif
-ifneq ($(CONFIG_PACKAGE_luci-mod-admin-full),)
+ifneq ($(CONFIG_PACKAGE_luci-admin-full),)
        PKG_SELECTED_MODULES+=modules/admin-full
 endif
+ifneq ($(CONFIG_PACKAGE_luci-admin-rpc),)
+       PKG_SELECTED_MODULES+=modules/rpc
+endif
 ifneq ($(CONFIG_PACKAGE_luci-mod-freifunk),)
        PKG_SELECTED_MODULES+=modules/freifunk
 endif
@@ -566,6 +698,19 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-statistics),)
        PKG_SELECTED_MODULES+=applications/luci-statistics
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-upnp),)
+       PKG_SELECTED_MODULES+=applications/luci-upnp
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-ntpc),)
+       PKG_SELECTED_MODULES+=applications/luci-ntpc
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-ddns),)
+       PKG_SELECTED_MODULES+=applications/luci-ddns
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-samba),)
+       PKG_SELECTED_MODULES+=applications/luci-samba
+endif
+
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
        PKG_SELECTED_MODULES+=libs/sgi-cgi
@@ -583,6 +728,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-theme-openwrt),)
        PKG_SELECTED_MODULES+=themes/openwrt.org
 endif
+ifneq ($(CONFIG_PACKAGE_luci-theme-openwrtlight),)
+       PKG_SELECTED_MODULES+=themes/openwrt-light
+endif
 
 ifneq ($(CONFIG_PACKAGE_luci-i18n-german),)
        PKG_SELECTED_MODULES+=i18n/german
@@ -593,6 +741,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-french),)
        PKG_SELECTED_MODULES+=i18n/french
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-russian),)
+       PKG_SELECTED_MODULES+=i18n/russian
+endif
 
 
 MAKE_FLAGS += \
@@ -608,8 +759,12 @@ $(eval $(call BuildPackage,luci-core))
 $(eval $(call BuildPackage,luci-cbi))
 $(eval $(call BuildPackage,luci-fastindex))
 $(eval $(call BuildPackage,luci-http))
+$(eval $(call BuildPackage,luci-ipkg))
+$(eval $(call BuildPackage,luci-json))
 $(eval $(call BuildPackage,luci-uci))
+$(eval $(call BuildPackage,luci-sys))
 $(eval $(call BuildPackage,luci-web))
+$(eval $(call BuildPackage,luci-uvl))
 
 $(eval $(call BuildPackage,luci-httpd))
 
@@ -619,9 +774,10 @@ $(eval $(call BuildPackage,luci-ff-hannover))
 $(eval $(call BuildPackage,luci-ff-berlin))
 $(eval $(call BuildPackage,luci-ff-augsburg))
 
-$(eval $(call BuildPackage,luci-mod-admin-core))
-$(eval $(call BuildPackage,luci-mod-admin-mini))
-$(eval $(call BuildPackage,luci-mod-admin-full))
+$(eval $(call BuildPackage,luci-admin-core))
+$(eval $(call BuildPackage,luci-admin-mini))
+$(eval $(call BuildPackage,luci-admin-full))
+$(eval $(call BuildPackage,luci-admin-rpc))
 $(eval $(call BuildPackage,luci-mod-freifunk))
 
 $(eval $(call BuildPackage,luci-app-ffwizard-leipzig))
@@ -630,6 +786,10 @@ $(eval $(call BuildPackage,luci-app-olsr))
 $(eval $(call BuildPackage,luci-app-qos))
 $(eval $(call BuildPackage,luci-app-splash))
 $(eval $(call BuildPackage,luci-app-statistics))
+$(eval $(call BuildPackage,luci-app-upnp))
+$(eval $(call BuildPackage,luci-app-ntpc))
+$(eval $(call BuildPackage,luci-app-ddns))
+$(eval $(call BuildPackage,luci-app-samba))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-luci))
@@ -637,7 +797,9 @@ $(eval $(call BuildPackage,luci-sgi-webuci))
 
 $(eval $(call BuildPackage,luci-theme-fledermaus))
 $(eval $(call BuildPackage,luci-theme-openwrt))
+$(eval $(call BuildPackage,luci-theme-openwrtlight))
 
 $(eval $(call BuildPackage,luci-i18n-german))
 $(eval $(call BuildPackage,luci-i18n-english))
 $(eval $(call BuildPackage,luci-i18n-french))
+$(eval $(call BuildPackage,luci-i18n-russian))