Outsourced IPKG abstraction to own directory
[project/luci.git] / contrib / package / luci / Makefile
index c9bf18cc9ec3544c21510a365fe763f6bf9dc45c..edd8949d0a15132d768516d96963008e6427e086 100644 (file)
@@ -55,37 +55,37 @@ define Package/luci/libtemplate
   TITLE:=LuCI - Lua Configuration Interface
   URL:=http://luci.freifunk-halle.net/
   MAINTAINER:=Steven Barth <steven-at-midlink-dot-org>
-  SUBMENU:=LuCI Libraries
+  SUBMENU:=LuCI Libraries
   DEPENDS:=+luci-core
 endef
 
 define Package/luci/fftemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI - Freifunk Support
-  DEPENDS:=+luci-mod-freifunk
+  SUBMENU:=LuCI Freifunk Support (PARTLY BROKEN)
+  DEPENDS:=+luci-mod-freifunk @BROKEN
 endef
 
 define Package/luci/httpdtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Non-Forking HTTP-Daemon (EXPERIMENTAL)
+  SUBMENU:=LuCI Non-Forking HTTP-Daemon (EXPERIMENTAL)
   DEPENDS:=+luci-httpd
 endef
 
 define Package/luci/i18ntemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Translations
+  SUBMENU:=LuCI Translations
   DEPENDS:=+luci-web
 endef
 
 define Package/luci/thtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI Themes
+  SUBMENU:=LuCI Themes
   DEPENDS:=+luci-web
 endef
 
 define Package/luci/webtemplate
   $(call Package/luci/libtemplate)
-  SUBMENU:=LuCI - Webinterface Components
+  SUBMENU:=LuCI Components
 endef
 
 
@@ -111,13 +111,16 @@ endef
 define Package/luci-core/config
        choice
                prompt "Build Target"
-               default PACKAGE_luci-core_compile
+               default PACKAGE_luci-core_source
 
        config PACKAGE_luci-core_compile
-               bool "Production"
+               bool "Precompiled"
+               
+       config PACKAGE_luci-core_stripped
+               bool "Stripped"
 
        config PACKAGE_luci-core_source
-               bool "Debug"
+               bool "Full Source"
 
        endchoice
 endef
@@ -126,6 +129,10 @@ ifneq ($(CONFIG_PACKAGE_luci-core_compile),)
   LUA_TARGET:=compile
 endif
 
+ifneq ($(CONFIG_PACKAGE_luci-core_stripped),)
+  LUA_TARGET:=strip
+endif
+
 
 ### Libraries ###
 define Package/luci-cbi
@@ -170,6 +177,16 @@ define Package/luci-http/install
 endef
 
 
+define Package/luci-ipkg
+  $(call Package/luci/libtemplate)
+  TITLE:=LuCI IPKG/OPKG call abstraction library 
+endef
+
+define Package/luci-ipkg/install
+       $(call Package/luci/install/template,$(1),libs/ipkg)
+endef
+
+
 define Package/luci-web
   $(call Package/luci/libtemplate)
   DEPENDS+=+luci-http +luci-addons +luci-uci +luci-sgi-cgi
@@ -267,23 +284,58 @@ define Package/luci-ff-berlin/install
        $(call Package/luci/install/template,$(1),applications/community-berlin)
 endef
 
+define Package/luci-ff-augsburg
+  $(call Package/luci/fftemplate)
+  DEPENDS+= \
+   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
+   +luci-theme-fledermaus \
+   +luci-i18n-german \
+   +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
+  TITLE:=Freifunk Augsburg Community Meta-Package
+endef
+
+define Package/luci-ff-augsburg/install
+        $(call Package/luci/install/template,$(1),applications/community-augsburg)
+endef
 
 ### Modules ###
 
-define Package/luci-mod-admin-core
+define Package/luci-admin-core
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-web +luci-cbi +luci-theme-openwrt +luci-i18n-english
-  TITLE:=Administration module
+  TITLE:=Web UI Core Module
 endef
 
-define Package/luci-mod-admin-core/install
+define Package/luci-admin-core/install
        $(call Package/luci/install/template,$(1),modules/admin-core)
 endef
 
 
+define Package/luci-admin-mini
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-core
+  TITLE:=LuCI Essentials - casual user's interface
+endef
+
+define Package/luci-admin-mini/install
+       $(call Package/luci/install/template,$(1),modules/admin-mini)
+endef
+
+
+define Package/luci-admin-full
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-core +luci-ipkg
+  TITLE:=LuCI Administration - power user's interface
+endef
+
+define Package/luci-admin-full/install
+       $(call Package/luci/install/template,$(1),modules/admin-full)
+endef
+
+
 define Package/luci-mod-freifunk
   $(call Package/luci/fftemplate)
-  DEPENDS:=+luci-mod-admin-core
+  DEPENDS:=+luci-admin-full
   TITLE:=LuCI Freifunk module
 endef
 
@@ -312,14 +364,10 @@ endef
 
 define Package/luci-app-firewall
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-core
+  DEPENDS+=+luci-admin-core +firewall
   TITLE:=Firewall and Portforwarding application
 endef
 
-define Package/luci-app-firewall/conffiles
-/etc/config/luci_fw
-endef
-
 define Package/luci-app-firewall/install
        $(call Package/luci/install/template,$(1),applications/luci-fw)
 endef
@@ -327,7 +375,7 @@ endef
 
 define Package/luci-app-olsr
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-core +olsrd-mod-txtinfo
+  DEPENDS+=+luci-admin-full +olsrd +olsrd-mod-txtinfo
   TITLE:=OLSR configuration and status module
 endef
 
@@ -338,7 +386,7 @@ endef
 
 define Package/luci-app-qos
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-core +qos-scripts
+  DEPENDS+=+luci-admin-core +qos-scripts
   TITLE:=Quality of Service configuration module
 endef
 
@@ -349,7 +397,7 @@ endef
 
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
-  DEPENDS+=+luasocket +iptables-mod-nat +iptables-mod-ipopt
+  DEPENDS+=+luasocket +firewall
   TITLE:=Freifunk DHCP-Splash application
 endef
 
@@ -364,7 +412,7 @@ endef
 
 define Package/luci-app-statistics
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-mod-admin-core +collectd +collectd-mod-rrdtool1 +rrdtool1
+  DEPENDS+=+luci-admin-full +collectd +collectd-mod-rrdtool1 +rrdtool1
   TITLE:=LuCI Statistics Application
 endef
 
@@ -377,6 +425,39 @@ define Package/luci-app-statistics/install
 endef
 
 
+define Package/luci-app-upnp
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-core +miniupnpd
+  TITLE:=Universal Plug & Play configuration module
+endef
+
+define Package/luci-app-upnp/install
+       $(call Package/luci/install/template,$(1),applications/luci-upnp)
+endef
+
+
+define Package/luci-app-ntpc
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-core +ntpclient
+  TITLE:=NTP time synchronisation client configuration module
+endef
+
+define Package/luci-app-ntpc/install
+       $(call Package/luci/install/template,$(1),applications/luci-ntpc)
+endef
+
+
+define Package/luci-app-ddns
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-core +ddns-scripts
+  TITLE:=Dynamic DNS configuration module
+endef
+
+define Package/luci-app-ddns/install
+       $(call Package/luci/install/template,$(1),applications/luci-ddns)
+endef
+
+
 ### Server Gateway Interfaces ###
 
 define Package/luci-sgi-cgi
@@ -473,6 +554,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-http),)
        PKG_SELECTED_MODULES+=libs/http
 endif
+ifneq ($(CONFIG_PACKAGE_luci-ipkg),)
+       PKG_SELECTED_MODULES+=libs/ipkg
+endif
 ifneq ($(CONFIG_PACKAGE_luci-uci),)
        PKG_SELECTED_MODULES+=libs/uci
 endif
@@ -496,10 +580,19 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-ff-berlin),)
        PKG_SELECTED_MODULES+=applications/community-berlin
 endif
+ifneq ($(CONFIG_PACKAGE_luci-ff-augsburg),)
+        PKG_SELECTED_MODULES+=applications/community-augsburg
+endif
 
-ifneq ($(CONFIG_PACKAGE_luci-mod-admin-core),)
+ifneq ($(CONFIG_PACKAGE_luci-admin-core),)
        PKG_SELECTED_MODULES+=modules/admin-core
 endif
+ifneq ($(CONFIG_PACKAGE_luci-admin-mini),)
+       PKG_SELECTED_MODULES+=modules/admin-mini
+endif
+ifneq ($(CONFIG_PACKAGE_luci-admin-full),)
+       PKG_SELECTED_MODULES+=modules/admin-full
+endif
 ifneq ($(CONFIG_PACKAGE_luci-mod-freifunk),)
        PKG_SELECTED_MODULES+=modules/freifunk
 endif
@@ -522,6 +615,15 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-statistics),)
        PKG_SELECTED_MODULES+=applications/luci-statistics
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-upnp),)
+       PKG_SELECTED_MODULES+=applications/luci-upnp
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-ntpc),)
+       PKG_SELECTED_MODULES+=applications/luci-ntpc
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-ddns),)
+       PKG_SELECTED_MODULES+=applications/luci-ddns
+endif
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
        PKG_SELECTED_MODULES+=libs/sgi-cgi
@@ -564,6 +666,7 @@ $(eval $(call BuildPackage,luci-core))
 $(eval $(call BuildPackage,luci-cbi))
 $(eval $(call BuildPackage,luci-fastindex))
 $(eval $(call BuildPackage,luci-http))
+$(eval $(call BuildPackage,luci-ipkg))
 $(eval $(call BuildPackage,luci-uci))
 $(eval $(call BuildPackage,luci-web))
 
@@ -572,8 +675,12 @@ $(eval $(call BuildPackage,luci-httpd))
 $(eval $(call BuildPackage,luci-ff-halle))
 $(eval $(call BuildPackage,luci-ff-leipzig))
 $(eval $(call BuildPackage,luci-ff-hannover))
+$(eval $(call BuildPackage,luci-ff-berlin))
+$(eval $(call BuildPackage,luci-ff-augsburg))
 
-$(eval $(call BuildPackage,luci-mod-admin-core))
+$(eval $(call BuildPackage,luci-admin-core))
+$(eval $(call BuildPackage,luci-admin-mini))
+$(eval $(call BuildPackage,luci-admin-full))
 $(eval $(call BuildPackage,luci-mod-freifunk))
 
 $(eval $(call BuildPackage,luci-app-ffwizard-leipzig))
@@ -582,6 +689,9 @@ $(eval $(call BuildPackage,luci-app-olsr))
 $(eval $(call BuildPackage,luci-app-qos))
 $(eval $(call BuildPackage,luci-app-splash))
 $(eval $(call BuildPackage,luci-app-statistics))
+$(eval $(call BuildPackage,luci-app-upnp))
+$(eval $(call BuildPackage,luci-app-ntpc))
+$(eval $(call BuildPackage,luci-app-ddns))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-luci))