Merge r4072
authorSteven Barth <steven@midlink.org>
Sat, 17 Jan 2009 13:53:03 +0000 (13:53 +0000)
committerSteven Barth <steven@midlink.org>
Sat, 17 Jan 2009 13:53:03 +0000 (13:53 +0000)
contrib/package/luci/Makefile
modules/admin-core/root/etc/init.d/luci_fixtime

index b4a978f2c214e7babe11fb6778848c0ccf8c2d44..01f7ca322add1361caf536afd9531e92f101fa45 100644 (file)
@@ -283,6 +283,7 @@ endef
 
 define Package/luci-admin-core/install
        $(call Package/luci/install/template,$(1),modules/admin-core)
+       touch $(1)/etc/init.d/luci_fixtime || true
 endef
 
 
index 681d9d7898bc33a8c2d2a20c1c5e8dc3937814d2..f300e45b9b52d9b216feabdd007e43339cef2e56 100755 (executable)
@@ -5,7 +5,7 @@ START=05
 start() {
        cat <<' EOF' | lua -l luci.fs -l luci.util -
                if (os.time() < 1000000000) then
-                       os.execute('date -s ' .. os.date('%m%d%H%M%Y', luci.fs.mtime(luci.util.libpath())))
+                       os.execute('date -s ' .. os.date('%m%d%H%M%Y', luci.fs.mtime("/etc/init.d/luci_fixtime")))
                end
        EOF
 }