Kill luci-addons package
authorSteven Barth <steven@midlink.org>
Tue, 23 Sep 2008 13:15:50 +0000 (13:15 +0000)
committerSteven Barth <steven@midlink.org>
Tue, 23 Sep 2008 13:15:50 +0000 (13:15 +0000)
17 files changed:
applications/luci-splash/root/etc/init.d/luci_splash
contrib/package/luci-addons/Makefile [deleted file]
contrib/package/luci-addons/dist/etc/config/luci_ethers [deleted file]
contrib/package/luci-addons/dist/etc/config/luci_hosts [deleted file]
contrib/package/luci-addons/dist/etc/crontabs/root [deleted file]
contrib/package/luci-addons/dist/etc/init.d/luci_ethers [deleted file]
contrib/package/luci-addons/dist/etc/init.d/luci_fixtime [deleted file]
contrib/package/luci-addons/dist/etc/init.d/luci_hosts [deleted file]
contrib/package/luci-addons/dist/sbin/luci-flash [deleted file]
contrib/package/luci-addons/dist/usr/bin/run-parts [deleted file]
contrib/package/luci/Makefile
modules/admin-core/root/etc/config/luci_ethers [new file with mode: 0644]
modules/admin-core/root/etc/config/luci_hosts [new file with mode: 0644]
modules/admin-core/root/etc/init.d/luci_ethers [new file with mode: 0755]
modules/admin-core/root/etc/init.d/luci_fixtime [new file with mode: 0755]
modules/admin-core/root/etc/init.d/luci_hosts [new file with mode: 0755]
modules/admin-core/root/sbin/luci-flash [new file with mode: 0755]

index 4761692b36780ac1af4be33c029d783716a80e40..85ea8ecaafc98fce8380b11d964d762cc164d504 100755 (executable)
@@ -61,6 +61,11 @@ start() {
        iptables -t nat -A luci_splash_leases -p tcp --dport 80 -j REDIRECT --to-ports 8082
        iptables -t nat -A luci_splash_leases -j DROP
        
+       ### Add crontab entry
+       grep luci-splash /var/spool/cron/crontabs/root >/dev/null 2>&1 || {
+               echo '*/5 * * * *       /usr/sbin/luci-splash sync' >> /var/spool/cron/crontabs/root
+       }
+
        ### Start the splash httpd
        start-stop-daemon -S -b -q -x /usr/bin/luci-splashd
 }
@@ -75,5 +80,8 @@ stop() {
        iptables -t nat -X luci_splash_leases
        iptables -t nat -X luci_splash_portal
        iptables -t nat -X luci_splash
+
+       ### Stop the splash httpd
+       start-stop-daemon -K -q -x /usr/bin/luci-splashd
 }
 
diff --git a/contrib/package/luci-addons/Makefile b/contrib/package/luci-addons/Makefile
deleted file mode 100644 (file)
index 294e77d..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=luci-addons
-PKG_VERSION:=0.3
-PKG_RELEASE:=1
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(INCLUDE_DIR)/package.mk
-
-
-define Build/Compile
-endef
-
-
-define Package/luci-addons
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=LuCI System Addons for Kamikaze
-  URL:=http://luci.freifunk-halle.net
-endef
-
-define Package/luci-addons/conffiles
-/etc/config/luci_hosts
-/etc/config/luci_ethers
-endef
-
-define Package/luci-addons/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_DIR) $(1)/etc/crontabs
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_DIR) $(1)/etc/config
-
-       $(INSTALL_BIN) ./dist/usr/bin/run-parts $(1)/usr/bin
-       $(INSTALL_BIN) ./dist/sbin/luci-flash $(1)/sbin
-       $(INSTALL_BIN) ./dist/etc/init.d/luci_fixtime $(1)/etc/init.d
-       $(INSTALL_BIN) ./dist/etc/init.d/luci_ethers $(1)/etc/init.d
-       $(INSTALL_BIN) ./dist/etc/init.d/luci_hosts $(1)/etc/init.d
-
-       $(INSTALL_CONF) ./dist/etc/config/luci_ethers $(1)/etc/config
-       $(INSTALL_CONF) ./dist/etc/config/luci_hosts $(1)/etc/config
-
-       $(CP) ./dist/etc/crontabs/root $(1)/etc/crontabs/root
-endef
-
-$(eval $(call BuildPackage,luci-addons))
diff --git a/contrib/package/luci-addons/dist/etc/config/luci_ethers b/contrib/package/luci-addons/dist/etc/config/luci_ethers
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/contrib/package/luci-addons/dist/etc/config/luci_hosts b/contrib/package/luci-addons/dist/etc/config/luci_hosts
deleted file mode 100644 (file)
index 6221df7..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-config 'host'
-       option 'ipaddr' '10.11.12.13'
-       option 'hostname' 'sample-host'
diff --git a/contrib/package/luci-addons/dist/etc/crontabs/root b/contrib/package/luci-addons/dist/etc/crontabs/root
deleted file mode 100644 (file)
index 1169c5c..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-* * * * *  /usr/bin/run-parts /etc/cron.minutely
-17 * * * *       /usr/bin/run-parts /etc/cron.hourly
-25 6 * * *       /usr/bin/run-parts /etc/cron.daily
diff --git a/contrib/package/luci-addons/dist/etc/init.d/luci_ethers b/contrib/package/luci-addons/dist/etc/init.d/luci_ethers
deleted file mode 100644 (file)
index 8cf4672..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh /etc/rc.common
-START=59
-
-apply_lease() {
-       local cfg="$1"
-
-       config_get macaddr "$cfg" macaddr
-       config_get ipaddr  "$cfg" ipaddr
-
-       [ -n "$macaddr" -a -n "$ipaddr" ] || return 0
-       
-       echo "$macaddr $ipaddr" >> /var/etc/ethers
-}
-
-start() {
-       if [ ! -L /etc/ethers ]; then
-               test -f /etc/ethers && mv /etc/ethers /etc/ethers.local
-               ln -s /var/etc/ethers /etc/ethers
-       fi
-
-       test -d /var/etc || mkdir -p /var/etc
-       
-       config_load luci_ethers
-       config_foreach apply_lease static_lease
-       
-       test -f /etc/ethers.local && cat /etc/ethers.local >> /var/etc/ethers
-       
-       return 0
-}
-
-stop() {
-       test -f /var/etc/ethers && rm -f /var/etc/ethers
-       
-       return 0
-}
diff --git a/contrib/package/luci-addons/dist/etc/init.d/luci_fixtime b/contrib/package/luci-addons/dist/etc/init.d/luci_fixtime
deleted file mode 100644 (file)
index 681d9d7..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=05
-
-start() {
-       cat <<' EOF' | lua -l luci.fs -l luci.util -
-               if (os.time() < 1000000000) then
-                       os.execute('date -s ' .. os.date('%m%d%H%M%Y', luci.fs.mtime(luci.util.libpath())))
-               end
-       EOF
-}
diff --git a/contrib/package/luci-addons/dist/etc/init.d/luci_hosts b/contrib/package/luci-addons/dist/etc/init.d/luci_hosts
deleted file mode 100644 (file)
index d01bfbb..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/sh /etc/rc.common
-START=60
-
-apply_host() {
-       local cfg="$1"
-
-       config_get hostname "$cfg" hostname
-       config_get ipaddr   "$cfg" ipaddr
-
-       [ -n "$hostname" -a -n "$ipaddr" ] || return 0
-       
-       echo "$ipaddr $hostname" >> /var/etc/hosts
-}
-
-start() {
-       if [ ! -L /etc/hosts ]; then
-               test -f /etc/hosts && mv /etc/hosts /etc/hosts.local
-               ln -s /var/etc/hosts /etc/hosts
-       fi
-
-       test -d /var/etc || mkdir -p /var/etc
-       test -f /etc/hosts.local && cat /etc/hosts.local >> /var/etc/hosts
-       
-       config_load luci_hosts
-       config_foreach apply_host host
-       
-       return 0
-}
-
-stop() {
-       test -f /var/etc/hosts && rm -f /var/etc/hosts
-       
-       return 0
-}
diff --git a/contrib/package/luci-addons/dist/sbin/luci-flash b/contrib/package/luci-addons/dist/sbin/luci-flash
deleted file mode 100755 (executable)
index 819be40..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/bin/sh
-. /etc/functions.sh
-
-# initialize defaults
-RAMFS_COPY_BIN="/usr/bin/awk"       # extra programs for temporary ramfs root
-RAMFS_COPY_DATA=""      # extra data files
-export KEEP_PATTERN=""
-export VERBOSE=0
-
-# parse options
-while [ -n "$1" ]; do
-        case "$1" in
-                -k)
-                               shift
-                               export SAVE_CONFIG=1
-                               export KEEP_PATTERN="$1"
-                ;;
-                -*)
-                        echo "Invalid option: $1"
-                        exit 1
-                ;;
-                *) break;;
-        esac
-        shift;
-done
-
-export CONFFILES=/tmp/sysupgrade.conffiles
-export CONF_TAR=/tmp/sysupgrade.tgz
-
-[ -f $CONFFILES ] && rm $CONFFILES
-[ -f $CONF_TAR ]  && rm $CONF_TAR
-
-export ARGV="$*"
-export ARGC="$#"
-
-[ -z "$ARGV" ] && {
-        cat <<EOF
-Usage: $0 [options] <image file or URL>
-
-Options:
-        -k     <"file 1, file 2, ..."> Files to be kept
-EOF
-        exit 1
-}
-
-add_pattern_conffiles() {
-       local file="$1"
-       find $KEEP_PATTERN >> "$file" 2>/dev/null
-       return 0
-}
-
-# hooks
-sysupgrade_image_check="platform_check_image"
-sysupgrade_init_conffiles=""
-
-[ -n "$KEEP_PATTERN" ] && append sysupgrade_init_conffiles "add_pattern_conffiles"
-
-include /lib/upgrade
-
-do_save_conffiles() {
-        [ -z "$(rootfs_type)" ] && {
-                echo "Cannot save config while running from ramdisk."
-                exit 3
-                return 0
-        }
-        run_hooks "$CONFFILES" $sysupgrade_init_conffiles
-
-        v "Saving config files..."
-        [ "$VERBOSE" -gt 1 ] && TAR_V="v" || TAR_V=""
-        tar c${TAR_V}zf "$CONF_TAR" -T "$CONFFILES" 2>/dev/null
-}
-
-type platform_check_image >/dev/null 2>/dev/null || {
-        echo "Firmware upgrade is not implemented for this platform."
-        exit 1
-}
-
-for check in $sysupgrade_image_check; do
-        ( eval "$check \"\$ARGV\"" ) || {
-                echo "Image check '$check' failed."
-                exit 2
-        }
-done
-
-[ -n "$sysupgrade_init_conffiles" ] && do_save_conffiles
-run_hooks "" $sysupgrade_pre_upgrade
-
-v "Switching to ramdisk..."
-run_ramfs '. /etc/functions.sh; include /lib/upgrade; do_upgrade'
diff --git a/contrib/package/luci-addons/dist/usr/bin/run-parts b/contrib/package/luci-addons/dist/usr/bin/run-parts
deleted file mode 100755 (executable)
index 0f0cbbd..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-set +e
-
-if [ $# -lt 1 ]; then
-        echo "Usage: run-parts <dir>"
-        exit 1
-fi
-
-if [ ! -d $1 ]; then
-        echo "Not a directory: $1"
-        exit 1
-fi
-
-for i in $1/*; do
-       [ -x $i ] && $i
-done
-       
-exit 0
\ No newline at end of file
index 2a67b33dd7a155672cf3402724526d529a72180f..1e87596e8e2cdedd0ccee5116dce7f9df8c0ea2c 100644 (file)
@@ -209,7 +209,7 @@ endef
 
 define Package/luci-web
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-http +luci-sys +luci-addons +luci-uci +luci-sgi-cgi
+  DEPENDS+=+luci-http +luci-sys +luci-uci +luci-sgi-cgi
   TITLE:=MVC Webframework
 endef
 
diff --git a/modules/admin-core/root/etc/config/luci_ethers b/modules/admin-core/root/etc/config/luci_ethers
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/modules/admin-core/root/etc/config/luci_hosts b/modules/admin-core/root/etc/config/luci_hosts
new file mode 100644 (file)
index 0000000..6221df7
--- /dev/null
@@ -0,0 +1,3 @@
+config 'host'
+       option 'ipaddr' '10.11.12.13'
+       option 'hostname' 'sample-host'
diff --git a/modules/admin-core/root/etc/init.d/luci_ethers b/modules/admin-core/root/etc/init.d/luci_ethers
new file mode 100755 (executable)
index 0000000..8cf4672
--- /dev/null
@@ -0,0 +1,35 @@
+#!/bin/sh /etc/rc.common
+START=59
+
+apply_lease() {
+       local cfg="$1"
+
+       config_get macaddr "$cfg" macaddr
+       config_get ipaddr  "$cfg" ipaddr
+
+       [ -n "$macaddr" -a -n "$ipaddr" ] || return 0
+       
+       echo "$macaddr $ipaddr" >> /var/etc/ethers
+}
+
+start() {
+       if [ ! -L /etc/ethers ]; then
+               test -f /etc/ethers && mv /etc/ethers /etc/ethers.local
+               ln -s /var/etc/ethers /etc/ethers
+       fi
+
+       test -d /var/etc || mkdir -p /var/etc
+       
+       config_load luci_ethers
+       config_foreach apply_lease static_lease
+       
+       test -f /etc/ethers.local && cat /etc/ethers.local >> /var/etc/ethers
+       
+       return 0
+}
+
+stop() {
+       test -f /var/etc/ethers && rm -f /var/etc/ethers
+       
+       return 0
+}
diff --git a/modules/admin-core/root/etc/init.d/luci_fixtime b/modules/admin-core/root/etc/init.d/luci_fixtime
new file mode 100755 (executable)
index 0000000..681d9d7
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common
+
+START=05
+
+start() {
+       cat <<' EOF' | lua -l luci.fs -l luci.util -
+               if (os.time() < 1000000000) then
+                       os.execute('date -s ' .. os.date('%m%d%H%M%Y', luci.fs.mtime(luci.util.libpath())))
+               end
+       EOF
+}
diff --git a/modules/admin-core/root/etc/init.d/luci_hosts b/modules/admin-core/root/etc/init.d/luci_hosts
new file mode 100755 (executable)
index 0000000..d01bfbb
--- /dev/null
@@ -0,0 +1,34 @@
+#!/bin/sh /etc/rc.common
+START=60
+
+apply_host() {
+       local cfg="$1"
+
+       config_get hostname "$cfg" hostname
+       config_get ipaddr   "$cfg" ipaddr
+
+       [ -n "$hostname" -a -n "$ipaddr" ] || return 0
+       
+       echo "$ipaddr $hostname" >> /var/etc/hosts
+}
+
+start() {
+       if [ ! -L /etc/hosts ]; then
+               test -f /etc/hosts && mv /etc/hosts /etc/hosts.local
+               ln -s /var/etc/hosts /etc/hosts
+       fi
+
+       test -d /var/etc || mkdir -p /var/etc
+       test -f /etc/hosts.local && cat /etc/hosts.local >> /var/etc/hosts
+       
+       config_load luci_hosts
+       config_foreach apply_host host
+       
+       return 0
+}
+
+stop() {
+       test -f /var/etc/hosts && rm -f /var/etc/hosts
+       
+       return 0
+}
diff --git a/modules/admin-core/root/sbin/luci-flash b/modules/admin-core/root/sbin/luci-flash
new file mode 100755 (executable)
index 0000000..819be40
--- /dev/null
@@ -0,0 +1,89 @@
+#!/bin/sh
+. /etc/functions.sh
+
+# initialize defaults
+RAMFS_COPY_BIN="/usr/bin/awk"       # extra programs for temporary ramfs root
+RAMFS_COPY_DATA=""      # extra data files
+export KEEP_PATTERN=""
+export VERBOSE=0
+
+# parse options
+while [ -n "$1" ]; do
+        case "$1" in
+                -k)
+                               shift
+                               export SAVE_CONFIG=1
+                               export KEEP_PATTERN="$1"
+                ;;
+                -*)
+                        echo "Invalid option: $1"
+                        exit 1
+                ;;
+                *) break;;
+        esac
+        shift;
+done
+
+export CONFFILES=/tmp/sysupgrade.conffiles
+export CONF_TAR=/tmp/sysupgrade.tgz
+
+[ -f $CONFFILES ] && rm $CONFFILES
+[ -f $CONF_TAR ]  && rm $CONF_TAR
+
+export ARGV="$*"
+export ARGC="$#"
+
+[ -z "$ARGV" ] && {
+        cat <<EOF
+Usage: $0 [options] <image file or URL>
+
+Options:
+        -k     <"file 1, file 2, ..."> Files to be kept
+EOF
+        exit 1
+}
+
+add_pattern_conffiles() {
+       local file="$1"
+       find $KEEP_PATTERN >> "$file" 2>/dev/null
+       return 0
+}
+
+# hooks
+sysupgrade_image_check="platform_check_image"
+sysupgrade_init_conffiles=""
+
+[ -n "$KEEP_PATTERN" ] && append sysupgrade_init_conffiles "add_pattern_conffiles"
+
+include /lib/upgrade
+
+do_save_conffiles() {
+        [ -z "$(rootfs_type)" ] && {
+                echo "Cannot save config while running from ramdisk."
+                exit 3
+                return 0
+        }
+        run_hooks "$CONFFILES" $sysupgrade_init_conffiles
+
+        v "Saving config files..."
+        [ "$VERBOSE" -gt 1 ] && TAR_V="v" || TAR_V=""
+        tar c${TAR_V}zf "$CONF_TAR" -T "$CONFFILES" 2>/dev/null
+}
+
+type platform_check_image >/dev/null 2>/dev/null || {
+        echo "Firmware upgrade is not implemented for this platform."
+        exit 1
+}
+
+for check in $sysupgrade_image_check; do
+        ( eval "$check \"\$ARGV\"" ) || {
+                echo "Image check '$check' failed."
+                exit 2
+        }
+done
+
+[ -n "$sysupgrade_init_conffiles" ] && do_save_conffiles
+run_hooks "" $sysupgrade_pre_upgrade
+
+v "Switching to ramdisk..."
+run_ramfs '. /etc/functions.sh; include /lib/upgrade; do_upgrade'