luci-0.8: merge r3828-r3829
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 29 Nov 2008 01:45:20 +0000 (01:45 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 29 Nov 2008 01:45:20 +0000 (01:45 +0000)
applications/luci-olsr/luasrc/model/cbi/olsr/olsrd.lua
contrib/package/olsrd-luci/Makefile
contrib/package/olsrd-luci/files/etc/init.d/olsrd

index 0f8bc423692b1d56813cee2dc4685a4b7f4ab595..4da1c4060dd44dd0119497c226140c1bb8053cbf 100644 (file)
@@ -114,6 +114,13 @@ i:option(Value, "MidValidityTime").optional = true
 i:option(Value, "HnaInterval").optional = true
 i:option(Value, "HnaValidityTime").optional = true
 
+ip6t = i:option(ListValue, "Ip6AddrType")
+ip6t:value("auto")
+ip6t:value("site-local")
+ip6t:value("unique-local")
+ip6t:value("global")
+ip6t.optional = true
+
 adc = i:option(Flag, "AutoDetectChanges")
 adc.enabled  = "yes"
 adc.disabled = "no"
index 8e22a7448f0e3fd41040af965b81cc27ca02c67d..8bb33499055e7971e8a6c4b335b5c1906a0888cb 100644 (file)
@@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
 PKG_BASENAME:=olsrd
 PKG_NAME:=$(PKG_BASENAME)-luci
 PKG_VERSION:=0.5.6-r2+hg1724
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_HGREV:=cac1df64dcd5
 PKG_SOURCE:=$(PKG_HGREV).tar.gz
index 9aee7a3664a29481711cefbff05e32af4d292976..aa2950acd4184a279b4c660a8be0df0e39e4e282 100755 (executable)
@@ -124,7 +124,7 @@ olsrd_write_option() {
        fi
 
        if [ "$value" != "${value%%[G-Zg-z_-]*}" ]; then
-               if [ "$value" != "yes" -a "$value" != "no" ]; then
+               if [ "$option" != "Ip6AddrType" -a "$value" != "yes" -a "$value" != "no" ]; then
                        value="\"$value\""
                fi
        fi