Build fixes
authorSteven Barth <steven@midlink.org>
Mon, 26 Oct 2009 13:24:36 +0000 (13:24 +0000)
committerSteven Barth <steven@midlink.org>
Mon, 26 Oct 2009 13:24:36 +0000 (13:24 +0000)
contrib/uci/Makefile
libs/nixio/src/fs.c

index 98e5ed439807a70f76d62677363e182900d64ade..19625aa723241363e47193247100ecf0a6e8393a 100644 (file)
@@ -23,12 +23,9 @@ $(UCI_FILE):
 $(UCI_PATCHDIR)/series:
        (cd $(UCI_PATCHDIR); ls *.patch | sort > series)
 
-$(UCI_DIR)/.prepared: $(UCI_PATCHDIR)/series $(UCI_FILE)
+$(UCI_DIR)/.prepared: $(UCI_FILE)
        rm -rf $(UCI_DIR)
        tar xvfz $(UCI_FILE)
-       while read patch; do \
-         patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
-       done < $(UCI_PATCHDIR)/series
        touch $@
 
 compile: $(UCI_DIR)/.prepared
index e21623b858fa15a0a904a06c9f1ff616ea26c480..53a406081ca527f3d6658a7b0efc7a4a20f7c1ef 100644 (file)
@@ -83,7 +83,7 @@ int nixio__check_mode(lua_State *L, int idx, int def) {
                if (i == 9) {   /* successfully parsed */
                        return mode;
                }
-       } else if (lua_isinteger(L, idx)) {
+       } else if (lua_isnumber(L, idx)) {
                int decmode = lua_tointeger(L, idx);
                int s = (decmode % 10000)       / 1000;
                int u = (decmode % 1000)        / 100;