trunk/contrib: use local checkout in Makefile to determine latest revision
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 29 Apr 2009 06:25:56 +0000 (06:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 29 Apr 2009 06:25:56 +0000 (06:25 +0000)
contrib/package/luci/Makefile

index 5795b4da32681e81ac85fb0b9d03dc4e2c34b39b..5fd6f4cc3d5fa06c53b6c3783ff8194ca5619368 100644 (file)
@@ -14,7 +14,7 @@ ifeq ($(USELOCAL),1)
 else
   PKG_SOURCE_URL:=http://svn.luci.subsignal.org/luci/$(PKG_BRANCH)
   ifeq ($(DUMP),)
 else
   PKG_SOURCE_URL:=http://svn.luci.subsignal.org/luci/$(PKG_BRANCH)
   ifeq ($(DUMP),)
-    PKG_REV:=$(shell LC_ALL=C svn info ${PKG_SOURCE_URL} | sed -ne's/^Revision: //p')
+    PKG_REV:=$(shell LC_ALL=C svn info $(CURDIR) | sed -ne's/^Revision: //p')
     PKG_VERSION:=0.9+svn$(PKG_REV)
   endif
   PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
     PKG_VERSION:=0.9+svn$(PKG_REV)
   endif
   PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)