luci-app-advanced-reboot: bugifx: btn style; board names for some Linksys devices 4384/head
authorStan Grishin <stangri@melmac.net>
Mon, 24 Aug 2020 02:14:14 +0000 (02:14 +0000)
committerStan Grishin <stangri@melmac.net>
Mon, 24 Aug 2020 02:14:14 +0000 (02:14 +0000)
Signed-off-by: Stan Grishin <stangri@melmac.net>
applications/luci-app-advanced-reboot/Makefile
applications/luci-app-advanced-reboot/README.md
applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-e4200v2.lua [new file with mode: 0644]
applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea3500.lua
applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea4500.lua [new file with mode: 0644]
applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/advanced_reboot.htm
applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/alternative_reboot.htm
applications/luci-app-advanced-reboot/luasrc/view/advanced_reboot/power_off.htm

index 79197c43ba04eb74e456c41712d87d6e23d03dd8..7be53efcb9550fa4caef682cc79de8ff80327471 100644 (file)
@@ -12,7 +12,7 @@ LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot
        routers are listed at https://github.com/openwrt/luci/blob/master/applications/luci-app-advanced-reboot/README.md
 LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full
 LUCI_PKGARCH:=all
-PKG_RELEASE:=54
+PKG_RELEASE:=55
 
 include ../../luci.mk
 
index 85c10fcc12260d3fcc11b0cb97697da96fe7d6fe..35b2d32d7be331880435d18fe4c11e0f1895fc8f 100644 (file)
@@ -1,5 +1,7 @@
 # Advanced Reboot Web UI (luci-app-advanced-reboot)
 
+[![HitCount](http://hits.dwyl.com/stangri/openwrt/luci-app-advanced-reboot.svg)](http://hits.dwyl.com/stangri/openwrt/luci-app-advanced-reboot)
+
 ## Description
 
 This package allows you to reboot to an alternative partition on the supported (dual-partition) routers and to power off (power down) your OpenWrt device.
diff --git a/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-e4200v2.lua b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-e4200v2.lua
new file mode 100644 (file)
index 0000000..50c4970
--- /dev/null
@@ -0,0 +1,14 @@
+return {
+       vendorName = "Linksys",
+       deviceName = "E4200v2",
+       boardNames = { "linksys-e4200v2", "linksys,e4200v2" },
+       partition1MTD = "mtd3",
+       partition2MTD = "mtd5",
+       labelOffset = 32,
+       bootEnv1 = "boot_part",
+       bootEnv1Partition1Value = 1,
+       bootEnv1Partition2Value = 2,
+       bootEnv2 = "bootcmd",
+       bootEnv2Partition1Value = "run nandboot",
+       bootEnv2Partition2Value = "run altnandboot"
+}
index 553788fd57a22f2bc88c0a099847770277d34d29..2b72cd4b7d5761c5eb1bd34cb06fe9a94026bce4 100644 (file)
@@ -1,7 +1,7 @@
 return {
        vendorName = "Linksys",
        deviceName = "EA3500",
-       boardNames = { "linksys-audi", "linksys,audi" },
+       boardNames = { "linksys-audi", "linksys,audi", "linksys-ea3500", "linksys,ea3500" },
        partition1MTD = "mtd3",
        partition2MTD = "mtd5",
        labelOffset = 32,
diff --git a/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea4500.lua b/applications/luci-app-advanced-reboot/luasrc/advanced-reboot/devices/linksys-ea4500.lua
new file mode 100644 (file)
index 0000000..10f53d1
--- /dev/null
@@ -0,0 +1,14 @@
+return {
+       vendorName = "Linksys",
+       deviceName = "EA4500",
+       boardNames = { "linksys-e4500", "linksys,e4500" },
+       partition1MTD = "mtd3",
+       partition2MTD = "mtd5",
+       labelOffset = 32,
+       bootEnv1 = "boot_part",
+       bootEnv1Partition1Value = 1,
+       bootEnv1Partition2Value = 2,
+       bootEnv2 = "bootcmd",
+       bootEnv2Partition1Value = "run nandboot",
+       bootEnv2Partition2Value = "run altnandboot"
+}
index 49985b32ceb5f0742b4a2ffd9f171b0034000039..a28418cc5f4ff484c036a3aca0a0f4acec58fe08 100644 (file)
                                <%- if bev1p1 == current_partition then -%>
                                <form method="post" action="<%=url('admin/system/advanced_reboot/reboot')%>">
                                        <input type="hidden" name="token" value="<%=token%>" />
-                                       <input id="reboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
+                                       <input id="reboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
                                </form>
                        <%- else -%>
                        <form method="post" action="<%=url('admin/system/advanced_reboot/alternative_reboot')%>">
                                <input type="hidden" name="token" value="<%=token%>" />
-                               <input id="altreboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
+                               <input id="altreboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
                        </form>
                                <%- end -%>
                        </div>
                                <%- if bev1p2 == current_partition then -%>
                                        <form method="post" action="<%=url('admin/system/advanced_reboot/reboot')%>">
                                                <input type="hidden" name="token" value="<%=token%>" />
-                                               <input id="reboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
+                                               <input id="reboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to current partition%>" />
                                        </form>
                                <%- else -%>
                                <form method="post" action="<%=url('admin/system/advanced_reboot/alternative_reboot')%>">
                                        <input type="hidden" name="token" value="<%=token%>" />
-                                       <input id="altreboot-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
+                                       <input id="altreboot-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Reboot to alternative partition...%>" />
                                </form>
                                <%- end -%>
                        </div>
@@ -91,7 +91,7 @@
 <%- if nixio.fs.access("/sbin/poweroff") then -%>
 <form method="post" action="<%=url('admin/system/advanced_reboot/power_off')%>">
        <input type="hidden" name="token" value="<%=token%>" />
-       <input id="poweroff-button" type="submit" class="cbi-button cbi-button-apply important" value="<%:Perform power off...%>" />
+       <input id="poweroff-button" type="submit" class="btn cbi-button cbi-button-apply important" value="<%:Perform power off...%>" />
 </form>
 <%- else -%>
        <p class="alert-message warning"><%:Warning: This system does not support powering off!%></p>
index db11020628f97f519e0f48514177e53e4219ed40..b81aaf4558877e9c05ccaef5a175306446d882c9 100644 (file)
@@ -21,8 +21,8 @@
        <form class="inline" action="<%=REQUEST_URI%>" method="post">
                <input type="hidden" name="token" value="<%=token%>" />
                <input type="hidden" name="step" value="2" />
-               <input class="cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
-               <input class="cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
+               <input class="btn cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
+               <input class="btn cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
        </form>
 </div>
 
index 1acf01b995169321c735ceff5b796df52ff28415..56200a4c1cc29d93fd770f9de85ffbe8cb3a062b 100644 (file)
@@ -17,8 +17,8 @@
        <form class="inline" action="<%=REQUEST_URI%>" method="post">
                <input type="hidden" name="token" value="<%=token%>" />
                <input type="hidden" name="step" value="2" />
-               <input class="cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
-               <input class="cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
+               <input class="btn cbi-button cbi-button-reset important" name="cancel" type="submit" value="<%:Cancel%>" />
+               <input class="btn cbi-button cbi-button-apply important" type="submit" value="<%:Proceed%>" />
        </form>
 </div>