* luci/contrib: add missing definitions for p910nd package in trunk makefile
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Sep 2008 22:26:41 +0000 (22:26 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Sep 2008 22:26:41 +0000 (22:26 +0000)
contrib/package/luci/Makefile

index 8a8418dcb9729edb9d2e1d3a4a188fd9f8c1ddd2..2a67b33dd7a155672cf3402724526d529a72180f 100644 (file)
@@ -458,6 +458,16 @@ define Package/luci-app-uvc_streamer/install
 endef
 
 
+define Package/luci-app-p910nd
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +p910nd
+  TITLE:=p910nd - Printer server module
+endef
+
+define Package/luci-app-p910nd/install
+        $(call Package/luci/install/template,$(1),applications/luci-p910nd)
+endef
+
 
 ### Server Gateway Interfaces ###
 
@@ -650,6 +660,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-uvc_streamer),)
        PKG_SELECTED_MODULES+=applications/luci-uvc_streamer
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-p910nd),)
+        PKG_SELECTED_MODULES+=applications/luci-p910nd
+endif
 
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
@@ -727,6 +740,7 @@ $(eval $(call BuildPackage,luci-app-ntpc))
 $(eval $(call BuildPackage,luci-app-ddns))
 $(eval $(call BuildPackage,luci-app-samba))
 $(eval $(call BuildPackage,luci-app-uvc_streamer))
+$(eval $(call BuildPackage,luci-app-p910nd))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-luci))