luci-0.10: merge r8792
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 27 Jun 2012 13:53:46 +0000 (13:53 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 27 Jun 2012 13:53:46 +0000 (13:53 +0000)
contrib/package/luci/Makefile
libs/sys/luasrc/sys.lua

index 362f2ac54044992d5c9f0fedcd7cceb1479d0304..3c90d49f04727b45837dec19db26de7474159ce6 100644 (file)
@@ -557,6 +557,7 @@ $(eval $(call translation,malay,Malay (by Teow Wai Chet)))
 $(eval $(call translation,norwegian,Norwegian (by Lars Hardy)))
 $(eval $(call translation,hebrew,Hebrew))
 $(eval $(call translation,romanian,Romanian))
+$(eval $(call translation,romanian2,Romanian2))
 
 
 ### Collections ###
index 9c30f55f6cf167cf58e9eb9ccc9a012449b229e9..75b6cb4a2d05308a4669b17fdeba9e5ea3de324b 100644 (file)
@@ -612,11 +612,10 @@ end
 -- @return                     Boolean indicating wheather the passwords are equal
 function user.checkpasswd(username, pass)
        local pwh = user.getpasswd(username)
-       if pwh and nixio.crypt(pass, pwh) ~= pwh then
-               return false
-       else
-               return true
+       if pwh then
+               return (nixio.crypt(pass, pwh) == pwh)
        end
+       return false
 end
 
 --- Change the password of given user.