applications: drop luci-lqtapifoss
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 14 Feb 2012 15:17:14 +0000 (15:17 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 14 Feb 2012 15:17:14 +0000 (15:17 +0000)
applications/luci-lqtapifoss/Makefile [deleted file]
applications/luci-lqtapifoss/luasrc/controller/lqtapifoss.lua [deleted file]
applications/luci-lqtapifoss/luasrc/model/cbi/luci_lqvoip/account.lua [deleted file]
applications/luci-lqtapifoss/luasrc/model/cbi/luci_lqvoip/config.lua [deleted file]
applications/luci-lqtapifoss/luasrc/model/cbi/luci_lqvoip/contact.lua [deleted file]
applications/luci-lqtapifoss/luasrc/view/luci_lqvoip/index.htm [deleted file]

diff --git a/applications/luci-lqtapifoss/Makefile b/applications/luci-lqtapifoss/Makefile
deleted file mode 100644 (file)
index 77925c4..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-PO = telephony
-
-include ../../build/config.mk
-include ../../build/module.mk
diff --git a/applications/luci-lqtapifoss/luasrc/controller/lqtapifoss.lua b/applications/luci-lqtapifoss/luasrc/controller/lqtapifoss.lua
deleted file mode 100644 (file)
index 323f8a7..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2019 John Crispin <blogic@openwrt.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-       http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-module("luci.controller.lqtapifoss", package.seeall)
-
-function index()
-       if not nixio.fs.access("/etc/config/telephony") then
-               return
-       end
-
-       local e
-
-       e = entry({"admin", "telephony"}, template("luci_lqvoip/index") , _("VoIP"), 90)
-       e.index = true
-       e.i18n = "telephony"
-
-       --entry({"admin", "telephony", "config"}, cbi("luci_lqvoip/config") , _("Config"), 10)
-       entry({"admin", "telephony", "account"}, cbi("luci_lqvoip/account") , _("Account"), 20)
-       entry({"admin", "telephony", "contact"}, cbi("luci_lqvoip/contact") , _("Contacts"), 30)
-end
diff --git a/applications/luci-lqtapifoss/luasrc/model/cbi/luci_lqvoip/account.lua b/applications/luci-lqtapifoss/luasrc/model/cbi/luci_lqvoip/account.lua
deleted file mode 100644 (file)
index e1ccceb..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2010 John Crispin <blogic@openwrt.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-       http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-m = Map("telephony", translate("VoIP"))
-m.on_after_commit = function() luci.sys.call("/etc/init.d/telephony restart") end
-
-s = m:section(NamedSection, "account", "account", translate("Account"),
-       translate("Here You can specify the SIP account that you want to use."))
-s.anonymous = false
-
-s:option(Value, "realm", translate("Realm"))
-s:option(Value, "username", translate("Username"))
-s:option(Value, "password", translate("Password"))
-s:option(Value, "stun", translate("STUN Server"))
-stun_port = s:option(Value, "stun_port", translate("STUN Port"))
-stun_port.default = "3478"
-sip_port = s:option(Value, "sip_port", translate("SIP Port"))
-sip_port.default = "5060"
-
-return m
diff --git a/applications/luci-lqtapifoss/luasrc/model/cbi/luci_lqvoip/config.lua b/applications/luci-lqtapifoss/luasrc/model/cbi/luci_lqvoip/config.lua
deleted file mode 100644 (file)
index 614bf45..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2010 John Crispin <blogic@openwrt.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-       http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-m = Map("telephony", translate("VoIP"))
-
-s = m:section(NamedSection, "config", "config", "Config", "Here You can specify the generic Configuration.")
-m.on_after_commit = function() luci.sys.call("/etc/init.d/telephony restart") end
-
-s:option(Value, "netdev", translate("Network"))
-
-e = s:option(ListValue, "fw_dl", translate("Download firmware"))
-e:value("0", translate("No"))
-e:value("1", translate("Yes"))
-e.default = "0"
-
-e = s:option(Value, "fw_url", translate("Firmware path"))
-e:depends("fw_dl", 1)
-
-return m
diff --git a/applications/luci-lqtapifoss/luasrc/model/cbi/luci_lqvoip/contact.lua b/applications/luci-lqtapifoss/luasrc/model/cbi/luci_lqvoip/contact.lua
deleted file mode 100644 (file)
index 09ee84c..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2010 John Crispin <blogic@openwrt.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-       http://www.apache.org/licenses/LICENSE-2.0
-
-]]--
-
-m = Map("telephony", translate("VoIP"))
-m.on_after_commit = function() luci.sys.call("/etc/init.d/telephony reload") end
-
-s = m:section(TypedSection, "contact", translate("Contact"), translate("Here You can specify the SIP contacts that you want to use."))
-s.anonymous = true
-s.addremove = true
-s.template = "cbi/tblsection"
-
-s:option(Value, "number", translate("Number"))
-s:option(Value, "identifier", translate("Identifier"))
-
-return m
diff --git a/applications/luci-lqtapifoss/luasrc/view/luci_lqvoip/index.htm b/applications/luci-lqtapifoss/luasrc/view/luci_lqvoip/index.htm
deleted file mode 100644 (file)
index 17b73cc..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-<%#
-LuCI - Lua Configuration Interface
-(c) 2009 Daniel Dickinson
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-       http://www.apache.org/licenses/LICENSE-2.0
-
-$Id: index.htm 5097 2009-07-17 20:27:05Z jow $
-
--%>
-<%+header%>
-<h2><a id="content" name="content">VoIP</a></h2>
-<p>Here you can control Lantiq voice-related settings</p>
-<%+footer%>