build: also find and remove .gitignore files when installing sources
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 16 Apr 2009 10:41:55 +0000 (10:41 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 16 Apr 2009 10:41:55 +0000 (10:41 +0000)
build/module.mk

index 66b767c7a12b111bad13cffae8c4b7538ad55f55..de86855beaf0a623b6aefadf5fee278db769ecc2 100644 (file)
@@ -27,7 +27,7 @@ luasource:
        cp -pR luasrc/* dist$(LUCI_MODULEDIR) 2>/dev/null || true
        cp -pR lua/* dist$(LUA_MODULEDIR) 2>/dev/null || true
        cp -pR htdocs/* dist$(HTDOCS) 2>/dev/null || true
-       for i in $$(find dist -name .svn); do rm -rf $$i || true; done
+       for i in $$(find dist -name .svn -or -name .gitignore); do rm -rf $$i || true; done
        for i in dist$(LUCI_MODULEDIR)/i18n/*.xml; do [ -f "$$i" ] && rm $$i; done || true