* Finished support for SGI CGI
authorSteven Barth <steven@midlink.org>
Sun, 15 Jun 2008 18:02:09 +0000 (18:02 +0000)
committerSteven Barth <steven@midlink.org>
Sun, 15 Jun 2008 18:02:09 +0000 (18:02 +0000)
contrib/package/luci/Makefile
libs/sgi-cgi/htdocs/cgi-bin/index.cgi [new file with mode: 0755]
libs/sgi-cgi/htdocs/index.html [new file with mode: 0644]

index 04229dac5f2aadeecb2859caf96252fdcd307a04..50156656d9769de4ba9d257c14a27da40574b0f4 100644 (file)
@@ -153,7 +153,7 @@ endef
 define Package/luci-ff-halle
   $(call Package/luci/fftemplate)
   DEPENDS+= \
-   +luci-sgi-haserl +luci-app-splash +luci-app-olsr \
+   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
    +luci-app-ffwizard-leipzig \
    +luci-theme-fledermaus \
    +luci-i18n-german \
@@ -170,7 +170,7 @@ endef
 define Package/luci-ff-leipzig
   $(call Package/luci/fftemplate)
   DEPENDS+= \
-   +luci-sgi-haserl +luci-app-splash +luci-app-olsr \
+   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
    +luci-app-ffwizard-leipzig \
    +luci-theme-fledermaus \
    +luci-i18n-german \
@@ -187,7 +187,7 @@ endef
 define Package/luci-ff-hannover
   $(call Package/luci/fftemplate)
   DEPENDS+= \
-   +luci-sgi-haserl +luci-app-splash +luci-app-olsr \
+   +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
    +luci-theme-fledermaus \
    +luci-i18n-german \
    +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
@@ -312,6 +312,16 @@ endef
 
 ### Server Gateway Interfaces ###
 
+define Package/luci-sgi-cgi
+  $(call Package/luci/libtemplate)
+  DEPENDS+=+luci-web
+  TITLE:=SGI for CGI
+endef
+
+define Package/luci-sgi-cgi/install
+       $(call Package/luci/install/template,$(1),libs/sgi-cgi)
+endef
+
 define Package/luci-sgi-haserl
   $(call Package/luci/libtemplate)
   DEPENDS+=+luci-web +haserl-lua
@@ -428,6 +438,9 @@ ifneq ($(CONFIG_PACKAGE_luci-app-statistics),)
        PKG_SELECTED_MODULES+=applications/luci-statistics
 endif
 
+ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
+       PKG_SELECTED_MODULES+=libs/sgi-cgi
+endif
 ifneq ($(CONFIG_PACKAGE_luci-sgi-haserl),)
        PKG_SELECTED_MODULES+=libs/sgi-haserl
 endif
@@ -473,6 +486,7 @@ $(eval $(call BuildPackage,luci-app-qos))
 $(eval $(call BuildPackage,luci-app-splash))
 $(eval $(call BuildPackage,luci-app-statistics))
 
+$(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-haserl))
 $(eval $(call BuildPackage,luci-sgi-webuci))
 
diff --git a/libs/sgi-cgi/htdocs/cgi-bin/index.cgi b/libs/sgi-cgi/htdocs/cgi-bin/index.cgi
new file mode 100755 (executable)
index 0000000..fc1148d
--- /dev/null
@@ -0,0 +1,3 @@
+#!/usr/bin/lua
+print("Status: 302 Found")
+print("Location: luci\n")
diff --git a/libs/sgi-cgi/htdocs/index.html b/libs/sgi-cgi/htdocs/index.html
new file mode 100644 (file)
index 0000000..39ba558
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml">
+<head>
+<meta http-equiv="refresh" content="0; URL=/cgi-bin/index.cgi" />
+</head>
+<body style="background-color: black">
+<a style="color: white; text-decoration: none" href="/cgi-bin/index.cgi">LuCI - Lua Configuration Interface</a>
+</body>
+</html>
\ No newline at end of file