build: allow overriding host cpu with make variable
[project/opkg-lede.git] / libbb / Makefile.am
index 1cc82df2d90bb5a38266f005c389a829e56eb941..19015770282ab7c249163c6d0be93bc0847639d9 100644 (file)
@@ -1,6 +1,6 @@
 HOST_CPU=@host_cpu@
 BUILD_CPU=@build_cpu@
-ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@
+ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@
 
 noinst_LTLIBRARIES = libbb.la