opkg: distcheck fixes
authorticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>
Mon, 15 Dec 2008 04:45:31 +0000 (04:45 +0000)
committerticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>
Mon, 15 Dec 2008 04:45:31 +0000 (04:45 +0000)
git-svn-id: http://opkg.googlecode.com/svn/trunk@36 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358

configure.ac
libopkg/Makefile.am
src/opkg-frontend.c
tests/Makefile.am
tests/opkg_extract_test.c
tests/opkg_hash_test.c

index a7e8fda166c1526cb87ca23c91decbdf504e9c48..e36b66486d428344ca8af9e3aff5c9d4e2407e85 100644 (file)
@@ -1,5 +1,5 @@
 # Process this file with autoconf to produce a configure script
-AC_INIT(libopkg/opkg.c)
+AC_INIT(libopkg/libopkg.c)
 AM_INIT_AUTOMAKE([opkg], [0.99.163])
 AM_CONFIG_HEADER(libopkg/config.h)
 
index a780825c9b1a6cfc6e80be338768e9d72aebacb1..3dcbea7d60e743d70827b444d508799525729401 100644 (file)
@@ -1,5 +1,5 @@
 
-ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_builddir)
+ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir)
 
 libopkg_includedir=$(includedir)/libopkg
 
index 47671d288984d20a804c8202949ef519c13562d0..08a3e4988f6d44a0762d5351a2f8a0a4c50d48ed 100644 (file)
@@ -18,7 +18,7 @@
    
 */
 
-#include "libopkg.h"
+#include <libopkg/libopkg.h>
 
 /* This is really small, eh? ;-) */
 
index f7be7ff7979e88f9154d966fffe29a07251ebcbf..fe67e9992ef63608c1d410d05c062f7be2669061 100644 (file)
@@ -3,10 +3,10 @@ noinst_PROGRAMS = opkg_hash_test opkg_extract_test
 
 opkg_hash_test_LDADD = $(top_builddir)/libbb/libbb.la $(top_builddir)/libopkg/libopkg.la
 opkg_hash_test_SOURCES = opkg_hash_test.c
-opkg_hash_test_CFLAGS = $(ALL_CFLAGS) -I$(top_builddir)
+opkg_hash_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
 
 opkg_extract_test_LDADD = $(top_builddir)/libbb/libbb.la $(top_builddir)/libopkg/libopkg.la
 opkg_extract_test_SOURCES = opkg_extract_test.c
-opkg_extract_test_CFLAGS = $(ALL_CFLAGS) -I$(top_builddir)
+opkg_extract_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
 
 
index 83e23e3e38f53f07498be9f4aefbec4718c3f8af..582ea714ce46e2d8302e767067926f644cac8d62 100644 (file)
@@ -1,6 +1,6 @@
 #include <stdio.h>
 #include <stdlib.h>
-#include "libbb/libbb.h"
+#include <libbb/libbb.h>
 
 /*
  * build thus: 
index 934dac70daf2687793d6d928d23b101ed007dc5f..7d4ea9686866a39368738b698940294d93af387f 100644 (file)
    General Public License for more details.
 */
 
-#include "opkg.h"
+#include <libopkg/opkg.h>
 
-#include "hash_table.h"
-#include "opkg_utils.h"
-#include "pkg_hash.h"
+#include <libopkg/hash_table.h>
+#include <libopkg/opkg_utils.h>
+#include <libopkg/pkg_hash.h>
 
 int main(int argc, char *argv[])
 {