cmake: Add ubox, blobmsg_json libraries and include dirs lookup
[project/ubus.git] / examples / CMakeLists.txt
index 0279f6e66b50cc4bc0207bf9dfc6f19b83548190..006dac42a27ca291174f9f98eaf3e5c7195b0b28 100644 (file)
@@ -5,8 +5,8 @@ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 
 IF (BUILD_EXAMPLES)
        ADD_EXECUTABLE(server server.c count.c)
-       TARGET_LINK_LIBRARIES(server ubus ubox blobmsg_json)
+       TARGET_LINK_LIBRARIES(server ubus ${ubox_library} ${blob_library})
 
        ADD_EXECUTABLE(client client.c count.c)
-       TARGET_LINK_LIBRARIES(client ubus ubox)
+       TARGET_LINK_LIBRARIES(client ubus ${ubox_library})
 ENDIF()