enable -Wmissing-declarations
authorFelix Fietkau <nbd@openwrt.org>
Mon, 28 May 2012 22:41:39 +0000 (00:41 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 28 May 2012 22:41:39 +0000 (00:41 +0200)
CMakeLists.txt

index 9057b3c72cba5390c7a54b93dcc8e15f6f17cfb5..9ecce85ef33af929f79255694e36b1e58c6e4f42 100644 (file)
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.6)
 
 PROJECT(ubus C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
 
 OPTION(BUILD_LUA "build Lua plugin" ON)