qualcommax: ipq807x: define common Linksys MX device
authorPaweł Owoc <frut3k7@gmail.com>
Wed, 13 Mar 2024 11:36:39 +0000 (12:36 +0100)
committerRobert Marko <robimarko@gmail.com>
Thu, 16 May 2024 18:27:36 +0000 (20:27 +0200)
Define common Linksys MX device for MX4200v1/v2 and MX5300.

Signed-off-by: Paweł Owoc <frut3k7@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/14883
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/qualcommax/image/ipq807x.mk

index e32250d45837157828556b1decba999f63cb6ed8..a4fd6ff7969044de012504a1aa52f6c7bca25555 100644 (file)
@@ -103,20 +103,26 @@ define Device/edimax_cax1800
 endef
 TARGET_DEVICES += edimax_cax1800
 
-define Device/linksys_mx4200v1
+define Device/linksys_mx
        $(call Device/FitImage)
        DEVICE_VENDOR := Linksys
-       DEVICE_MODEL := MX4200
-       DEVICE_VARIANT := v1
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        KERNEL_SIZE := 6144k
        IMAGE_SIZE := 147456k
        NAND_SIZE := 512m
-       SOC := ipq8174
+       SOC := ipq8072
        IMAGES += factory.bin
-       IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=MX4200
-       DEVICE_PACKAGES := kmod-leds-pca963x ipq-wifi-linksys_mx4200 kmod-bluetooth
+       IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=$$$$(DEVICE_MODEL)
+       DEVICE_PACKAGES := kmod-leds-pca963x
+endef
+
+define Device/linksys_mx4200v1
+       $(call Device/linksys_mx)
+       DEVICE_MODEL := MX4200
+       DEVICE_VARIANT := v1
+       SOC := ipq8174
+       DEVICE_PACKAGES += ipq-wifi-linksys_mx4200 kmod-bluetooth
 endef
 TARGET_DEVICES += linksys_mx4200v1
 
@@ -127,19 +133,10 @@ endef
 TARGET_DEVICES += linksys_mx4200v2
 
 define Device/linksys_mx5300
-       $(call Device/FitImage)
-       DEVICE_VENDOR := Linksys
+       $(call Device/linksys_mx)
        DEVICE_MODEL := MX5300
-       BLOCKSIZE := 128k
-       PAGESIZE := 2048
-       KERNEL_SIZE := 6144k
-       IMAGE_SIZE := 147456k
-       NAND_SIZE := 512m
-       SOC := ipq8072
-       IMAGES += factory.bin
-       IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=MX5300
-       DEVICE_PACKAGES := kmod-leds-pca963x kmod-rtc-ds1307 \
-               ipq-wifi-linksys_mx5300 kmod-ath10k-ct ath10k-firmware-qca9984-ct
+       DEVICE_PACKAGES += kmod-rtc-ds1307 ipq-wifi-linksys_mx5300 \
+               kmod-ath10k-ct ath10k-firmware-qca9984-ct
 endef
 TARGET_DEVICES += linksys_mx5300