Revert "kernel: add rtl8723au driver (staging)"
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 15 Jun 2015 07:46:55 +0000 (07:46 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 15 Jun 2015 07:46:55 +0000 (07:46 +0000)
This one cannot possibly work, as it depends on cfg80211, which is built
out of tree.

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Backport of r45985

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@45986 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/wireless.mk

index 13511dd..2627b57 100644 (file)
@@ -72,27 +72,6 @@ endef
 
 $(eval $(call KernelPackage,net-rtl8188eu))
 
-
-define KernelPackage/net-rtl8723au
-  SUBMENU:=$(WIRELESS_MENU)
-  TITLE:=RTL8723AU support (staging)
-  DEPENDS:=@USB_SUPPORT +@DRIVER_WEXT_SUPPORT +r8188eu-firmware +kmod-usb-core
-  KCONFIG:=\
-        CONFIG_STAGING=y \
-        CONFIG_R8723AU \
-        CONFIG_8723AU_AP_MODE=y \
-        CONFIG_8723AU_BT_COEXIST=y
-  FILES:=$(LINUX_DIR)/drivers/staging/rtl8723au/r8723au.ko
-  AUTOLOAD:=$(call AutoProbe,r8723au)
-endef
-
-define KernelPackage/net-rtl8723au/description
- Kernel modules for RealTek RTL8723AU support
-endef
-
-$(eval $(call KernelPackage,net-rtl8723au))
-
-
 define KernelPackage/net-rtl8192su
   SUBMENU:=$(WIRELESS_MENU)
   TITLE:=RTL8192SU support (staging)