Revert "bzip2: extend/fix the Host/Install rule to install libbz2.so files"
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Dec 2015 11:29:42 +0000 (11:29 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Dec 2015 11:29:42 +0000 (11:29 +0000)
This reverts r47245.

Linking to shared libraries under $STAGING_DIR_HOST{,/usr}/lib is harmful,
as these directories aren't added to LD_LIBRARY_PATH (see r47103 for an
explanation why LD_LIBRARY_PATH is not used).

Revert to static linking; in particular, this fixes the build of the python
bz2 module on OpenSUSE and Fedora (which in turn broke the build of
nodejs).

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Backport of r47950

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47951 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/utils/bzip2/Makefile

index ba47cfb..4ad9684 100644 (file)
@@ -97,10 +97,8 @@ HOST_CONFIGURE_ARGS+= \
        --prefix=$(STAGING_DIR_HOST)
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/ $(STAGING_DIR_HOST)/usr/lib
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
        $(MAKE) -C $(HOST_BUILD_DIR) PREFIX=$(STAGING_DIR_HOST)/usr/ install
-       $(CP) $(HOST_BUILD_DIR)/libbz2.so* $(STAGING_DIR_HOST)/usr/lib/
-       $(CP) $(HOST_BUILD_DIR)/libbz2.so.1.0 $(STAGING_DIR_HOST)/usr/lib/libbz2.so
 endef
 
 $(eval $(call HostBuild))