bison: replace the yacc script with one that does not hardcode the path (fixes #20605)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Sep 2015 21:11:16 +0000 (21:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Sep 2015 21:11:16 +0000 (21:11 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Backport of r47050

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47051 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/bison/Makefile
tools/bison/scripts/yacc [new file with mode: 0755]

index 10d8720..2565121 100644 (file)
@@ -23,4 +23,9 @@ define Host/Clean
        $(call Host/Clean/Default)
 endef
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
 $(eval $(call HostBuild))
diff --git a/tools/bison/scripts/yacc b/tools/bison/scripts/yacc
new file mode 100755 (executable)
index 0000000..8f73e26
--- /dev/null
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec bison -y "$@"