tools: drop circular dependency between patch and ccache, build patch without ccache...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 26 Jul 2015 13:02:35 +0000 (13:02 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 26 Jul 2015 13:02:35 +0000 (13:02 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Backport of r46434

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46498 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/patch/Makefile

index 2f516d2..d2fe2ff 100644 (file)
@@ -73,7 +73,7 @@ $(curdir)/gengetopt/compile := $(curdir)/libtool/install
 $(curdir)/patchelf/compile := $(curdir)/libtool/install
 
 ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
+$(foreach tool, $(filter-out patch,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
 tools-y += ccache
 endif
 
index 94b3607..4774478 100644 (file)
@@ -15,4 +15,7 @@ PKG_MD5SUM:=e3da7940431633fb65a01b91d3b7a27a
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOSTCC := $(HOSTCC_NOCACHE)
+HOSTCXX := $(HOSTCXX_NOCACHE)
+
 $(eval $(call HostBuild))