hostapd: properly enable 802.11w support
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Aug 2015 12:43:22 +0000 (12:43 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Aug 2015 12:43:22 +0000 (12:43 +0000)
Add CONFIG_IEEE80211W variable to DRIVER_MAKEOPTS so that 802.11w
support is properly compiled in full variant.

This fixes #20179

Signed-off-by: Janusz Dziemidowicz <rraptorr@nails.eu.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46737 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/hostapd/Makefile

index 3dff7b4..c16cb11 100644 (file)
@@ -71,7 +71,7 @@ DRIVER_MAKEOPTS= \
        CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
 
 ifeq ($(LOCAL_VARIANT),full)
-  CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
+  DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
 endif
 
 ifneq ($(LOCAL_TYPE),hostapd)