hostapd: fix eglibc 2.15 support
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Apr 2014 18:30:50 +0000 (18:30 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Apr 2014 18:30:50 +0000 (18:30 +0000)
This patch fixes compilation failure for hostapd when using eglibc 2.15.

Signed-off-by: Zachery Stoddard <zacherystoddard@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40575 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/hostapd/Makefile

index 2e8eae2..80e0082 100644 (file)
@@ -88,6 +88,7 @@ endif
 
 ifdef CONFIG_USE_EGLIBC
   TARGET_LDFLAGS += -lrt
+  TARGET_LDFLAGS_C += -lrt
 endif
 
 DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!TARGET_avr32||BROKEN)
@@ -267,7 +268,7 @@ define Build/RunMake
                $(TARGET_CONFIGURE_OPTS) \
                $(DRIVER_MAKEOPTS) \
                LIBS="$(TARGET_LDFLAGS)" \
-               LIBS_c="" \
+               LIBS_c="$(TARGET_LDFLAGS_C)" \
                BCHECK= \
                $(2)
 endef