Revert "build: use ONESHELL to speed up scanning and the toplevel makefile"
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Oct 2014 10:47:26 +0000 (10:47 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Oct 2014 10:47:26 +0000 (10:47 +0000)
This seems to cause issues on some build hosts, and it is not that
important.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43025 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
include/scan.mk
include/target.mk

index f75fc7f..91b6946 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,6 @@ empty:=
 space:= $(empty) $(empty)
 $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
 
-.ONESHELL:
 world:
 
 include $(TOPDIR)/include/host.mk
index 2f2753f..0998333 100644 (file)
@@ -78,4 +78,3 @@ $(TMP_DIR)/.$(SCAN_TARGET): $(TARGET_STAMP) $(SCAN_STAMP)
 FORCE:
 .PHONY: FORCE
 .NOTPARALLEL:
-.ONESHELL:
index 657109e..3401f84 100644 (file)
@@ -19,7 +19,6 @@ DEFAULT_PACKAGES.bootloader:=
 
 ifneq ($(DUMP),)
   all: dumpinfo
-  .ONESHELL:
 endif
 
 target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))