[packages] cppunit: Add new package cppunit for doing c++ unit testing
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jan 2011 08:36:46 +0000 (08:36 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jan 2011 08:36:46 +0000 (08:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25190 3c298f89-4303-0410-b956-a3cf2f4a3e73

devel/cppunit/Makefile [new file with mode: 0644]

diff --git a/devel/cppunit/Makefile b/devel/cppunit/Makefile
new file mode 100644 (file)
index 0000000..42fa3f2
--- /dev/null
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cppunit
+PKG_VERSION:=1.12.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/cppunit
+PKG_MD5SUM:=bd30e9cf5523cdfc019b94f5e1d7fd19
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/cppunit
+  SECTION:=devel
+  CATEGORY:=Development
+  TITLE:=Unit Testing Library for C++
+  URL:=http://cppunit.sourceforge.net/
+endef
+
+define Package/cppunit/description
+  Unit Testing Library for C++
+endef
+
+define Build/InstallDev
+       echo InstallDev installing to $(1)
+       $(INSTALL_DIR) $(1)/usr/include/cppunit
+       $(CP) $(PKG_BUILD_DIR)/include/cppunit $(1)/usr/include/cppunit/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/src/cppunit/.libs/libcppunit*so* $(1)/usr/lib/
+endef
+
+define Package/cppunit/install
+       echo install installing to $(1)
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/src/cppunit/.libs/libcppunit*so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,cppunit))