luci.mk: remove unnecessary i18n postinst script
authorHannu Nyman <hannu.nyman@iki.fi>
Sat, 20 Apr 2024 09:19:26 +0000 (12:19 +0300)
committerHannu Nyman <hannu.nyman@iki.fi>
Sat, 20 Apr 2024 09:19:26 +0000 (12:19 +0300)
OpenWrt master has since 2016 run the uci-defaults also in run-time installations
as postinst:
openwrt/openwrt@9b9c78e

Remove the older separate implementation from LuCI.

Fixes #7070 and #7073

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
luci.mk

diff --git a/luci.mk b/luci.mk
index c26dfbbf2aa9fa6b75bb229f8b91482f74af2662..b5bd6fcd13a899dc85f55566a6be7a9ac7f8dbb6 100644 (file)
--- a/luci.mk
+++ b/luci.mk
@@ -341,13 +341,6 @@ define LuciTranslation
                        $$(1)$(LUCI_LIBRARYDIR)/i18n/$(basename $(notdir $(po))).$(1).lmo;)
   endef
 
-  define Package/luci-i18n-$(LUCI_BASENAME)-$(1)/postinst
-       [ -n "$$$${IPKG_INSTROOT}" ] || {
-               (. /etc/uci-defaults/luci-i18n-$(LUCI_BASENAME)-$(1)) && rm -f /etc/uci-defaults/luci-i18n-$(LUCI_BASENAME)-$(1)
-               exit 0
-       }
-  endef
-
   LUCI_BUILD_PACKAGES += luci-i18n-$(LUCI_BASENAME)-$(1)
 
 endef