add -Wmissing-declarations to cflags
authorFelix Fietkau <nbd@openwrt.org>
Wed, 19 Oct 2011 19:15:26 +0000 (21:15 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 19 Oct 2011 19:15:26 +0000 (21:15 +0200)
CMakeLists.txt

index a57123e31c3402d2478b251b78f595975af35610..adb2c071432da9fc97a60d4855dc4a021ffb4ce2 100644 (file)
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.6)
 
 PROJECT(netifd C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations)
 
 SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")