luci-0.9: merge r4885
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 21 Jun 2009 11:47:08 +0000 (11:47 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 21 Jun 2009 11:47:08 +0000 (11:47 +0000)
contrib/package/sysupgrade-atheros/Makefile

index 43c7fee69b8dff05075c20505c2ceb9122234a6b..7b20d8537b48e16cd7a2921d5509c694fd8e1c04 100644 (file)
@@ -40,10 +40,8 @@ endef
 define Package/sysupgrade-atheros/postinst
 #!/bin/sh
 [ -n "$${IPKG_INSTROOT}" ] || {
-  if ! grep -q /etc/firewall.freifunk /etc/config/firewall; then
-    uci add firewall include >/dev/null
-    uci set firewall.@include[-1].path=/etc/firewall.freifunk
-    uci commit firewall
+  if [ -f /lib/upgrade/kill-ffwatchd.sh ]; then
+    rm -f /lib/upgrade/kill-ffwatchd.sh
   fi
 }
 endef