gdb: Update to 13.2
[openwrt/staging/wigyori.git] / package / devel / gdb / Makefile
index 359a11be2b0c2fb98d2924a045a031aa8c9ec34d..20a40eb8bbed63b1dd00c7a0143ac39436c43415 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,29 +8,32 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=7.8
+PKG_VERSION:=13.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_MD5SUM:=bd958fe9019d7c7896f29f6724a764ed
+PKG_HASH:=fd5bebb7be1833abdb6e023c2f498a354498281df9d05523d8915babeb893f0a
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
+PKG_LICENSE:=GPL-3.0+
+PKG_CPE_ID:=cpe:/a:gnu:gdb
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/gdb/Default
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:=@!(avr32||cris) +!USE_MUSL:libthread-db +PACKAGE_zlib:zlib
-  URL:=http://www.gnu.org/software/gdb/
+  DEPENDS:=+!USE_MUSL:libthread-db $(ICONV_DEPENDS) $(INTL_DEPENDS)
+  URL:=https://www.gnu.org/software/gdb/
 endef
 
 define Package/gdb
 $(call Package/gdb/Default)
   TITLE:=GNU Debugger
-  DEPENDS+=+libreadline +libncurses +zlib
+  DEPENDS+=+libreadline +libncurses +zlib +libgmp
 endef
 
 define Package/gdb/description
@@ -52,24 +55,33 @@ endef
 # XXX: add --disable-werror to prevent build failure with arm
 CONFIGURE_ARGS+= \
        --with-system-readline \
+       --with-system-zlib \
        --without-expat \
-       --disable-werror
+       --without-lzma \
+       --disable-unit-tests \
+       --disable-ubsan \
+       --disable-sim \
+       --disable-werror \
+       --disable-source-highlight \
+       --without-mpc \
+       --without-mpfr \
+       --without-isl \
+       --without-xxhash \
+       --with-libgmp-prefix=$(STAGING_DIR)/usr
 
 CONFIGURE_VARS+= \
        ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
 
-define Build/Compile
-       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               all
-endef
+TARGET_LDFLAGS+= \
+       $(INTL_LDFLAGS) $(if $(INTL_FULL),-lintl) \
+       -static-libstdc++ \
+       -Wl,--gc-sections
 
 define Build/Install
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               install-gdb
+               install-gdb install-gdbserver
 endef
 
 define Package/gdb/install