gdb: Update to 13.2
authorHannu Nyman <hannu.nyman@iki.fi>
Tue, 7 Nov 2023 18:55:58 +0000 (20:55 +0200)
committerNick Hainke <vincent@systemli.org>
Fri, 10 Nov 2023 07:39:38 +0000 (08:39 +0100)
Update the devel/gdb package to version 13.2

* Remove the upstreamed patch 001-Add-support-for-readline-8.2.patch
* Adjust 130-gdb-ctrl-c.patch to upstream changes

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
package/devel/gdb/Makefile
package/devel/gdb/patches/001-Add-support-for-readline-8.2.patch [deleted file]
package/devel/gdb/patches/110-shared_libgcc.patch
package/devel/gdb/patches/130-gdb-ctrl-c.patch

index 4c0d6469a2fbf56f1a1fbfab15c656856d7750e8..20a40eb8bbed63b1dd00c7a0143ac39436c43415 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=12.1
-PKG_RELEASE:=3
+PKG_VERSION:=13.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=0e1793bf8f2b54d53f46dea84ccfd446f48f81b297b28c4f7fc017b818d69fed
+PKG_HASH:=fd5bebb7be1833abdb6e023c2f498a354498281df9d05523d8915babeb893f0a
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
diff --git a/package/devel/gdb/patches/001-Add-support-for-readline-8.2.patch b/package/devel/gdb/patches/001-Add-support-for-readline-8.2.patch
deleted file mode 100644 (file)
index eb93c7f..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 1add37b567a7dee39d99f37b37802034c3fce9c4 Mon Sep 17 00:00:00 2001
-From: Andreas Schwab <schwab@linux-m68k.org>
-Date: Sun, 20 Mar 2022 14:01:54 +0100
-Subject: [PATCH] Add support for readline 8.2
-
-In readline 8.2 the type of rl_completer_word_break_characters changed to
-include const.
----
- gdb/completer.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/gdb/completer.c
-+++ b/gdb/completer.c
-@@ -36,7 +36,7 @@
-    calling a hook instead so we eliminate the CLI dependency.  */
- #include "gdbcmd.h"
--/* Needed for rl_completer_word_break_characters() and for
-+/* Needed for rl_completer_word_break_characters and for
-    rl_filename_completion_function.  */
- #include "readline/readline.h"
-@@ -2011,7 +2011,7 @@ gdb_completion_word_break_characters_thr
-       rl_basic_quote_characters = NULL;
-     }
--  return rl_completer_word_break_characters;
-+  return (char *) rl_completer_word_break_characters;
- }
- char *
index f1602bc69506e7129a885894e2b39d789b933230..44d4ffa77f358bbbe48d223520ac9c069c9d5c40 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1314,13 +1314,13 @@ if test -z "$LD"; then
+@@ -1435,13 +1435,13 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -17,7 +17,7 @@
    AC_LANG_PUSH(C++)
    AC_LINK_IFELSE([AC_LANG_SOURCE([
  #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
-@@ -1719,7 +1719,7 @@ AC_ARG_WITH(stage1-ldflags,
+@@ -1838,7 +1838,7 @@ AC_ARG_WITH(stage1-ldflags,
   # trust that they are doing what they want.
   if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
       -a "$have_static_libs" = yes; then
@@ -26,7 +26,7 @@
   fi])
  AC_SUBST(stage1_ldflags)
  
-@@ -1748,7 +1748,7 @@ AC_ARG_WITH(boot-ldflags,
+@@ -1867,7 +1867,7 @@ AC_ARG_WITH(boot-ldflags,
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
@@ -37,7 +37,7 @@
  
 --- a/configure
 +++ b/configure
-@@ -5275,14 +5275,14 @@ if test -z "$LD"; then
+@@ -5442,14 +5442,14 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -56,7 +56,7 @@
    ac_ext=cpp
  ac_cpp='$CXXCPP $CPPFLAGS'
  ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -6167,7 +6167,7 @@ else
+@@ -8440,7 +8440,7 @@ else
   # trust that they are doing what they want.
   if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
       -a "$have_static_libs" = yes; then
@@ -65,7 +65,7 @@
   fi
  fi
  
-@@ -6203,7 +6203,7 @@ else
+@@ -8476,7 +8476,7 @@ else
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
index f793a71cae0222e5abe6d1e4108f9147ef701e51..8650ce844c7770ad7758dba47047421d6e5de948 100644 (file)
@@ -24,12 +24,12 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
 
 --- a/gdbserver/linux-low.cc
 +++ b/gdbserver/linux-low.cc
-@@ -5496,7 +5496,7 @@ linux_process_target::request_interrupt
+@@ -5467,7 +5467,7 @@ linux_process_target::request_interrupt
  {
    /* Send a SIGINT to the process group.  This acts just like the user
       typed a ^C on the controlling terminal.  */
--  ::kill (-signal_pid, SIGINT);
-+  ::kill (signal_pid, SIGINT);
- }
- bool
+-  int res = ::kill (-signal_pid, SIGINT);
++  int res = ::kill (signal_pid, SIGINT);
+   if (res == -1)
+     warning (_("Sending SIGINT to process group of pid %ld failed: %s"),
+            signal_pid, safe_strerror (errno));