gdb: Update to 13.2
[openwrt/staging/wigyori.git] / package / devel / gdb / Makefile
index a3579969917ec144f65300eca60de2cec85adfcb..20a40eb8bbed63b1dd00c7a0143ac39436c43415 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=10.2
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=13.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=aaa1223d534c9b700a8bec952d9748ee1977513f178727e1bee520ee000b4f29
+PKG_HASH:=fd5bebb7be1833abdb6e023c2f498a354498281df9d05523d8915babeb893f0a
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
@@ -33,7 +33,7 @@ endef
 define Package/gdb
 $(call Package/gdb/Default)
   TITLE:=GNU Debugger
-  DEPENDS+=+libreadline +libncurses +zlib
+  DEPENDS+=+libreadline +libncurses +zlib +libgmp
 endef
 
 define Package/gdb/description
@@ -62,7 +62,12 @@ CONFIGURE_ARGS+= \
        --disable-ubsan \
        --disable-sim \
        --disable-werror \
-       --disable-source-highlight
+       --disable-source-highlight \
+       --without-mpc \
+       --without-mpfr \
+       --without-isl \
+       --without-xxhash \
+       --with-libgmp-prefix=$(STAGING_DIR)/usr
 
 CONFIGURE_VARS+= \
        ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"