gdb: Update to 13.2
[openwrt/staging/wigyori.git] / package / devel / gdb / patches / 110-shared_libgcc.patch
index f1602bc69506e7129a885894e2b39d789b933230..44d4ffa77f358bbbe48d223520ac9c069c9d5c40 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1314,13 +1314,13 @@ if test -z "$LD"; then
+@@ -1435,13 +1435,13 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -17,7 +17,7 @@
    AC_LANG_PUSH(C++)
    AC_LINK_IFELSE([AC_LANG_SOURCE([
  #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
-@@ -1719,7 +1719,7 @@ AC_ARG_WITH(stage1-ldflags,
+@@ -1838,7 +1838,7 @@ AC_ARG_WITH(stage1-ldflags,
   # trust that they are doing what they want.
   if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
       -a "$have_static_libs" = yes; then
@@ -26,7 +26,7 @@
   fi])
  AC_SUBST(stage1_ldflags)
  
-@@ -1748,7 +1748,7 @@ AC_ARG_WITH(boot-ldflags,
+@@ -1867,7 +1867,7 @@ AC_ARG_WITH(boot-ldflags,
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
@@ -37,7 +37,7 @@
  
 --- a/configure
 +++ b/configure
-@@ -5275,14 +5275,14 @@ if test -z "$LD"; then
+@@ -5442,14 +5442,14 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -56,7 +56,7 @@
    ac_ext=cpp
  ac_cpp='$CXXCPP $CPPFLAGS'
  ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -6167,7 +6167,7 @@ else
+@@ -8440,7 +8440,7 @@ else
   # trust that they are doing what they want.
   if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
       -a "$have_static_libs" = yes; then
@@ -65,7 +65,7 @@
   fi
  fi
  
-@@ -6203,7 +6203,7 @@ else
+@@ -8476,7 +8476,7 @@ else
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then